It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I'll change the wording for the next release to make it clearer :)
Edit: Solved after installing lib32-alsa-plugins lib32-libpulse lib32-openal. Found on the archlinux forum, but unfortunately: "You cannot post any links at this moment."

Hello,

Thanks for this script! I'm running civ4 on Archlinux. The game starts correctly, but I have no sound (I'm using pulseaudio). Any idea?

Here is the output in the console:

Current desktop resolution: 1920x1200
Detected 5 display output(s). Connected outputs:
DP-1: 1920x1200
WARNING: Could not determine the primary display resolution. Using desktop resolution as fallback.
Gamma (R/G/B) = 1.000 / 1.000 / 1.000
Wine version: wine-4.0
Prefix is 32-bit
WARNING: VIDEOS_DIRNAME is blank!
Userdata directory: /home/david/.local/share/civ4complete
Running: Civilization4.exe
Working directory: /data/civ4/Civilization IV Complete/prefix/drive_c/Civilization IV Complete/Civ4
Not forcing virtual desktop
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
Wine cannot find the ncurses library (libncurses.so.5).
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
'import site' failed; use -v for traceback
-> Red 1.000, Green 1.000, Blue 1.000
<- Red 1.000, Green 1.000, Blue 1.000
Post edited January 02, 2020 by dfroger
On my machine (archlinunx, wine-5.0-rc3) only the food ressources are displayed, I don't see production (see attached the image). Any idea? thanks.

Edit: I installed various libs with winetricks, and that fixed the problem. Still can't post URL :) ... This was in the HowTo of the civ4 page of wine
Attachments:
food.jpg (402 Kb)
Post edited January 02, 2020 by dfroger
Can I please get some help installing any mod, even just Bug if not Buffy, onto Civ4 under Linux.
I can't offer much help as I've been extremely busy lately - in addition to everything else I have going on I'm currently working through updating all wrappers to Wine 5.0 where possible, updating any bundled fixes/etc. and rechecking/fixing things as necessary so my time is quite limited right now.

Anyway if you use my wrapper mods should work (or at least BUFFY should), as per the details in this post: https://www.gog.com/forum/sid_meiers_civilization_series/civilization_iv_for_linux/post21 (there were some missing registry entries at the time but that issue has long been fixed). There are also details for the missing registry entries in later posts if you want to use your own setup instead of my wrapper.
Just gave this a try and played a full short game. Apart from me not having played this in ages, i had no problems at all.
The nostalgia is unreal, thank you so much for making this work.
avatar
Shampoocat: Just gave this a try and played a full short game. Apart from me not having played this in ages, i had no problems at all.
The nostalgia is unreal, thank you so much for making this work.
Excellent, then everything should be fine :) I had a problem at the time when running the Hall of Fame mod (for competitive play), and it turned out some registry entries were needed. Believe this is part of Adam's script now, but I found this link as well, so if the game doesn't work as expected, it's worth a shot: https://pastebin.com/8ZL76K5m (it's a .reg file)
avatar
Shampoocat: Just gave this a try and played a full short game. Apart from me not having played this in ages, i had no problems at all.
The nostalgia is unreal, thank you so much for making this work.
avatar
Pangaea666: Excellent, then everything should be fine :) I had a problem at the time when running the Hall of Fame mod (for competitive play), and it turned out some registry entries were needed. Believe this is part of Adam's script now, but I found this link as well, so if the game doesn't work as expected, it's worth a shot: https://pastebin.com/8ZL76K5m (it's a .reg file)
Only Mod I played with so far is FFH2, I simply used an crappy old laptop with windows to run the exe files and then copy pasted the resulting folders in to appropriate location in the wine installation. Worked without any issues.
works like charm ... thanks for wrapper

please consider to make of them official project on github
Post edited July 23, 2020 by frity