It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Cannot run the game. Every time i try to launch the game, i get Terran.exe Application Error. Check picture for details. I tried Compatible mode for windows XP (sp3) but no work. I have windows 10 X64 creators update.
Attachments:
error.jpg (42 Kb)
No posts in this topic were marked as the solution yet. If you can help, add your reply
I solved the problem. I have to do some Alpha Centauri.Ini tweaking, to get game working
avatar
shadow1980jpv: I solved the problem. I have to do some Alpha Centauri.Ini tweaking, to get game working
What tweaks did you make? I'm having the same problem. Get an 0xc0000022 error
avatar
shadow1980jpv: I solved the problem. I have to do some Alpha Centauri.Ini tweaking, to get game working
avatar
elkaboom1971: What tweaks did you make? I'm having the same problem. Get an 0xc0000022 error
This tweaking:

[PREFERENCES]
ForceOldVoxelAlgorithm=1
[Alpha Centauri]

DirectDraw=0
ds3d=0
eax=0
FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16
DisableOpeningMovie=0
Prefs Format=12
Map Type=0
Top Menu=3
Faction=2
Preferences=10111011111000011101110110110110
More Preferences=1110100111000101101000
Semaphore=00000000
Announce=111100001110101001
Rules=1101000001110
Customize=2
Custom World=3, 1, 1, 1, 1, 1, 1,
Time Controls=1

Compatibility mode must be Windows 7 not Windows Xp (sp3)

I also let game program run as an administrator
I have the exact same OS as you and did the tweaking, launched in W7 compatibility mode as admin. But it didn't work.
I did that tweaking too, i run the game on Win 10 64b and still have that error ... Anyone got a way of fixing this ?
win10
Start or close the windows function legacy component select DirectPlay
I made it!
avatar
Mazamune: I did that tweaking too, i run the game on Win 10 64b and still have that error ... Anyone got a way of fixing this ?
Start or close the windows function legacy component select DirectPlay
avatar
shadow1980jpv: I solved the problem. I have to do some Alpha Centauri.Ini tweaking, to get game working
avatar
elkaboom1971: What tweaks did you make? I'm having the same problem. Get an 0xc0000022 error
Start or close the windows function legacy component select DirectPlay
Post edited June 25, 2017 by ywchongjing
avatar
ywchongjing: win10
Start or close the windows function legacy component select DirectPlay
I made it!
avatar
Mazamune: I did that tweaking too, i run the game on Win 10 64b and still have that error ... Anyone got a way of fixing this ?
avatar
ywchongjing: Start or close the windows function legacy component select DirectPlay
avatar
elkaboom1971: What tweaks did you make? I'm having the same problem. Get an 0xc0000022 error
avatar
ywchongjing: Start or close the windows function legacy component select DirectPlay
I have no idea what any of this means...but I get the same error. I run Windows 10 and do not have any idea how to make the game run. I'm a little upset that I paid money and can't play the game.
avatar
ywchongjing: win10
Start or close the windows function legacy component select DirectPlay
I made it!

Start or close the windows function legacy component select DirectPlay

Start or close the windows function legacy component select DirectPlay
avatar
shanedal: I have no idea what any of this means...but I get the same error. I run Windows 10 and do not have any idea how to make the game run. I'm a little upset that I paid money and can't play the game.
I don't have Windows 10, but I'm sure if you search for: "Start or close the windows function legacy component select DirectPlay" there will be a webpage to help you.

Also, go to wherever you installed the game and open Alpha Centauri.ini and replace what's there with this.
Okay, I followed the tips that ywchonjing left and found some slightly clearer instructions that ended up working for me:

1. Go to "Programs and Features"
-Easiest way I found was go to the "Uninstall or change a program", and there is a "Related Settings: Programs and Features" in the upper right corner.

2. On the left side of that panel there is a "Turn Windows features on or off"

3. Scroll down the list to "Legacy Components" and check the box. Open it up and make sure that "DirectPlay" is checked.

4. Windows should automatically download something at this point. It worked after that.

I also replaced the .ini as the post above me recommended. Without that replacement the video seemed shaky and unhappy with two monitors, and with it everything seemed to run more smoothly. It did not, however, appear required.
I had to make one channge to the settings above:

DisableOpeningMovie=1
avatar
elkaboom1971: What tweaks did you make? I'm having the same problem. Get an 0xc0000022 error
avatar
shadow1980jpv: This tweaking:

[PREFERENCES]
ForceOldVoxelAlgorithm=1
[Alpha Centauri]

DirectDraw=0
ds3d=0
eax=0
FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16
DisableOpeningMovie=0
Prefs Format=12
Map Type=0
Top Menu=3
Faction=2
Preferences=10111011111000011101110110110110
More Preferences=1110100111000101101000
Semaphore=00000000
Announce=111100001110101001
Rules=1101000001110
Customize=2
Custom World=3, 1, 1, 1, 1, 1, 1,
Time Controls=1

Compatibility mode must be Windows 7 not Windows Xp (sp3)

I also let game program run as an administrator
I only see

ds3d=0
eax=0


What's wrong?