It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

OK I fixed it and here is how (note that I haven't done an extended play yet but this works to get into the game)

First, I got the game from GOG but if you run it using the GOG Galaxy it will at best not work and at worst it will completely crash your X server (or whatever the MacOS calls it?). The Mac GUI recovers but any programs you had open will have been shut down which is a bit annoying.

To get around that you need to get a copy of Paul the Tall's Porting Kit (likely Crossover will work too but I haven't tested that).

Then download the "offline installer" from your GOG account.

Now in the Porting Kit create a new Wrapper and select the WS11WineCX64Bit19.0.1 engine.

Install the game using the .exe downloaded from GOG.

Next, go to the options for the new Wrapper in Porting Kit and select "Wineskin Tools->Launch Wineskin"

From here go to "Advanced" and select "Winetricks". (note: I had to do it this way because if you simply select "Install Winetricks" from the wrapper menu the Porting Kit will complain about not being able to find a DISPLAY and ask you to install Zenity.

Install the Winetricks "directplay" and "ddr=gdi"

The game should now work, although "directplay" may not have actually installed since when I check "Port Details" from the Porting Kit wrapper it doesn't list directplay there...anyway that's what I did.

Also when I was playing around I did select "Wine Configuration" and changed the Windows version to XP but not sure if that makes a difference too.
MastaMind: I have Catalina installed and I was able to get Alpha Centauri to run...

You need a new wrapper (use Porting Kit) and install game with a Wrapper with WS11WineCX64Bit19.0.1 Engine....

It runs very smoothly...
deaves: I’ve tried doing this. The game loads and the open video sequence launches and then after it is done the video just hangs. The game never goes to the menu to initiate a game. Any advice would be super helpful.
As Glenwalker mentions, DDR=GDI is required for the sequences. I will make a port of it (replace the native which is not working in Catalina to the the port)) this week in Porting Kit making it an automatic process, a note is that you need the "offline backup setup" exe file and not the GOG Galaxy setup.
Is it possible to run the Porting Kit on macOS Catalina without disabling SIP?