It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

For all I know, this might not be a bug, but I can't seem to hit anything with my missiles. To reliably hit a target, I need to be at point blank range and aiming for the head. If I do anything else, my missile will somehow miss the enemy, even if it doesn't move at all and my targeting cursor is squarely over my enemy. I've seen youtube videos of people playing this game, and their missiles seem more accurate than mine; any ideas on how I can improve hit detection?
This question / problem has been solved by ZamFearimage
The hit detection just isn't very good, period.
For missiles, aim at the ground under your target, and destroy them with splash damage.
Not just missiles fail in my game. Lasers too must be aimed on head or fail. It's a shame, because i remember to shot legs all the time in this game. Now some enemies are impossible to shot on legs or body(the stick legged and chicken-lizrds ones) thus, making then almost invincible opponents. When i an out of missiles to shot in ground, and laser to shot seeking "secret" shootable parts at distance, my missions fail. I must hope the mission got some missiles in groung, because primary weapon isn't working. And missiles only work with a workaroung(nice tactic, but still the only option).
I need help. I'm using an Athlonx4 2600MHz with 4gb memory DDR2-800MHz and Radeon 4670(yeah, i really like this game like this, to use it there).
ZamFear: The hit detection just isn't very good, period.
Correction, the game simply does not run well on today's computers, even through dosbox or virtual machines.

I bought this game years ago when it came out and the hit detection was perfect playing it on a Pentium 2.
Guns, missiles, lasers, they all hit their mark perfectly requiring very little shots.

On computers of now, you will see half of your shots flying through the enemy, making some missions unbeatable because you will run out of ammo.

Playing with the cycles=# in dosbox.conf helps a little but still far from perfect. Other than a pure old PC, I see no way of properly playing this game.

Zemacaco's points in this thread:
are identical to mine. Anybody who bought and played this game when it came out in 1996 will verify this.
Post edited October 29, 2010 by MystMan
I have found if you upgrade to Dosbox version 0.74 and add the cputype= setting to your dosbox.conf the game seems to run much better. I use cputype-pentium_slow and now the collision detection for the missiles seems to have improved without as much choppiness of just reducing the cpu cycles. So under [cpu] in dosbox.conf it looks like this:


May help.
Post edited June 23, 2011 by LiqMat
0.74 makes all the difference. The previous version didn't work properly with SS.

I ended up using core=dynamic and cycles=75000 (lower was slower). Cycles=max might be okay too. It's hard to tell if the game's running fast or as intended.