It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Even after I deactivate 4:3 option, the game still runs in 4:3 leaving those annoying black bars on my screen! Has anyone experienced that too? is there any way to display the game correctly ?