It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


I'm on a Debian Testing ("Buster") system and can't start Shadwen. Using the script i get the following console output:

Running Shadwen
nohup: redirecting stdout to stderr

But then nothing happens and no process is spawned. I tried to start the binary manually by navigating to the "game" folder and using the following command:

LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:lib/lib64/ bin/shadwen_linux_64bit

Then i get a segmentation fault message. I managed to make the launcher binary run after i manually got me a version of libpng12 and placed the shared object file in the folder "game/lib/lib64", but the main binary refuses to run.

Any ideas about what i could do?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Your Problem looks like it has the same symptoms I had when I tried to get the game working on Ubuntu 18.04.

The reason it wasn't working for me was Shadwen requires OpenGL version 4.1 and mesa supports version 3.3 on my card currently

running in a shell the command:
glxinfo | grep OpenGL

Should show you what OpenGL version Mesa Reports that it currently supports.

Here is the output from my computer:

OpenGL vendor string: X.Org
OpenGL renderer string: AMD TURKS (DRM 2.50.0 / 4.15.0-42-generic, LLVM 6.0.0)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

In My Case The Turks Pro card should support OpenGL 4.5 however the r600 Driver currently only partially supports it.

I was able to get the game working with my Turks Pro By setting all the graphics setting to their lowest in the game launcher and using the following Environment Variable.
Disclaimer to my Knowledge the following should be safe but use at your own risk I am not responsible for damage to your computer etc.

Setting the environment variable:
to 4.1 got it working in my case

I hope that helps

I had the same problem on Zorin (Ubuntu 18.04) and Manjaro. I was able to get Shadwen running with three steps.

1. Install the appropriate libpng12 package for your distro
Debian based, Ubuntu etc.: sudo apt install libpng12-0
Arch based, Manjaro etc. : sudo pacman -Sy libpng12

2. cd GOG\ Games/Shadwen/game/
3. bin/

I can run it with high settings, 4K and fullscreen . Have fun :-) . Sorry no fun, see next post...
Post edited March 25, 2020 by Enginnsson
Well it continues to crash at same point of game every time. Will request for payback...