It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
So I have a Lenovo ideapad Laptop running Windows 10 Family (pre-installed, the laptop being brand new I decided not to tinker with the OS and such) with 4Gb of RAM and an Intel Core i5-7200 CPU @ 2.5GHz.

Shadow Warrior Classic Redux simply won't start.
When I run the game, the map pack selection screen shows up. I can then click on an option.

Then the game will load, the screen "flash" blank, trying to switch to the default resolution the game uses at the first startup, then flashes back to the desktop and the process is nowhere to be found in taskmgr.
Running the game as Administrator or changing the compatibility mode to Windows 7 doesn't change anything.

Also, I have installed the game on the only hard drive on the laptop (main drive), not on the recovery partition, nor have I created a separate partition for the games.
The path is simple : C:\GOG Games\Shadow Warrior Classic Redux.
I tried installing to a shorter path (you never know), but it didn't change anything.

Has anyone encountered the same problem?
Could it be a problem with the VC++ Redist?
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Megacyclo: Then the game will load, the screen "flash" blank, trying to switch to the default resolution the game uses at the first startup, then flashes back to the desktop and the process is nowhere to be found in taskmgr.
Running the game as Administrator or changing the compatibility mode to Windows 7 doesn't change anything.

[...]

Has anyone encountered the same problem?
Could it be a problem with the VC++ Redist?
Afaik it could occur due to any number of reasons, vc redist being one of them but hardly the only one (the directory path was rarely an issue with gog titles for me though, and never with newer releases such as redux version).

Try editing the resolution directly in the configuration file: locate sw-redux-local.cfg in the game's folder, open it with any text editor (Notepad will suffice), type in the values for ScreenWidth and ScreenHeight variables according to your native resolution.

Alternatively, you can try disabling fullscreen by changing ScreenMode option in the same file: it's probably set to 1 for fullscreen mode, type 0 for windowed. Maybe lower the resolution below your native one, too (just make sure it's the one your display supports). This too should get you into main menu, where you can set the desired resolution and mode, usually it sticks around and works.
Post edited September 03, 2018 by FattyJoker
Thank you very much for your reply and your suggestions, but in the end it was something much stupider than that, something I realised when I tried running Blood II and Unreal Gold on the same computer :

I had not turned off automatic DEP. Turning it off for anything but standard Windows processes fixed it.

Thank you anyway, if the problem reoccurs I'll keep your tips handy.