It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I installed this great nostalgia game today hoping to play it and sadly could not. The video’s sound fine but are a bit pixelated. That I can live with from an older game. That is fine, but when I got to the Starting screen the mouse is very laggy, jumping across the screen.
I have tried all the fixes I can find on the forums. I have installed the older quicktime player. Changed the CPUidle, copyed files into the SysWOS64 folder, made sure than “enhance pointer precision” is un-checked. All to no avail.
The only thing I found that would fix the problem is deleting the ddraw.dll, but this changes the screen resolution. I have a widescreen monitor (1440X900) with the Dll I can see everything fine but mouse does not work right and game runs slow. Without Dll everything runs fine and mouse works fine, but videos are gone and i can live with that if i have to, but resolution changes and I lose part of the right and bottom of the screen.
If anyone can help it would be appreciated. I really want to play this game again as I never got to finish it the first time around. Adding my comp specs below if they are needed, yes I know they are out of date but should easily be able to run this game.

Windows 10 Pro 64-bit
AMD A4-3400 APU with Radeon(tm) HD Graphics, 2700 Mhz
8GB Ram
NVIDIA GeForce GT 630

Thanks In Advance for any Help anyone can give.

Update:
According to GOG support:
"Unfortunately your operating system is not supported in this game. We weren't able to make the game work reliably on our test computers running that system. Because of this, this system is not listed among the compatible ones on the product page. I apologize for the inconvenience."
If there is a fix they dont have it at this time, but may come up with it. They have graciously refunded me for the game so i no longer have it at this time. I would remove this post but am not sure how as it has been resolved as much as can be at this time.
Post edited August 24, 2017 by spwolftech
No posts in this topic were marked as the solution yet. If you can help, add your reply
That's a shame. I bought this game years ago when Windows 7 was the current OS from Microsoft. I went to play the game for the first time in a while and ran into the mouse issue. Of course all my PCs are running Windows 10 now so I'm probably out of luck.

Hopefully a fix will be found for this at some point. I never did finish the game but I had enjoyed what I had played of it.
I'm having this issue too. Just reinstalled the game. : / Win 10 x64 Pro
avatar
Leucius: I'm having this issue too. Just reinstalled the game. : / Win 10 x64 Pro
Had the same issue. Just installed the game and the mouse was really slow.

Fixed this with help of this thread:
https://www.gog.com/forum/septerra_core_legacy_of_the_creator/fix_for_windows_10_works_100/page1

works like a charm now.
avatar
Leucius: I'm having this issue too. Just reinstalled the game. : / Win 10 x64 Pro
avatar
Flexflexible: Had the same issue. Just installed the game and the mouse was really slow.

Fixed this with help of this thread:
https://www.gog.com/forum/septerra_core_legacy_of_the_creator/fix_for_windows_10_works_100/page1

works like a charm now.
Thanks. I will look into trying this fix. It probably should be included in the game.
This fix works for me for some reason , no idea why .

Open septerra.cfg and edit the following :

[Options]
English = 1
CPUIdle = 0
ScaleMode = 1.5
avatar
norby1989: This fix works for me for some reason , no idea why .

Open septerra.cfg and edit the following :

[Options]
English = 1
CPUIdle = 0
ScaleMode = 1.5
This worked for me on Windows 10 and I also set the short-cut properties to run in 640x480 screen resolution.
The game runs perfect with these settings on my machine.