It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
The game was working fine.
After updating to Mac OS High Sierra after lunching the game nothing happen but the icon of the game popping on the dock bar as the application is running.
But nothing's up, neither can close the app. The only thing that I can do is to force quit Septerra.

EDIT:

SOLUTION BY "SirDmitry" ON STEAM FORUM (TESTED ALSO ON GOG VERSION)

"SirDmitry
Press RMB on game in gamelist. Go to the "LocalFiles" tab. Then "Show local Files". In Finder window press RMB on game, then choose "show package". Open wineskin, go to "Set Screen Options". Uncheck "Auto Detect GPU info for Direct3D". Close wineskin, enjoy.

Btw - same works for many other games in High sierra."
Post edited May 09, 2018 by linuxvangog
This question / problem has been solved by paol3tto87image
Solved.
Please any MOD close/cancel thread or leave it as reference as you wish.

MAnd if possible mark as solved, can't do it myself on my own post
Post edited May 05, 2018 by paol3tto87
avatar
paol3tto87: The game was working fine.
After updating to Mac OS High Sierra after lunching the game nothing happen but the icon of the game popping on the dock bar as the application is running.
But nothing's up, neither can close the app. The only thing that I can do is to force quit Septerra.

EDIT:

SOLUTION BY "SirDmitry" ON STEAM FORUM (TESTED ALSO ON GOG VERSION)

"SirDmitry
Press RMB on game in gamelist. Go to the "LocalFiles" tab. Then "Show local Files". In Finder window press RMB on game, then choose "show package". Open wineskin, go to "Set Screen Options". Uncheck "Auto Detect GPU info for Direct3D". Close wineskin, enjoy.

Btw - same works for many other games in High sierra."
Yo, this fix isn't working for Mojave! OR it may because I'm a MAc Newbie, but I can't find these options anywhere. I can access Show Package contents but no trace of Wineskin.