It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The Problem
I was unable to launch the game. Wine kept on giving me a Program Error notification while the screen remained black forever. I tried all manners of troubleshooting and nothing worked.
This was the notification (abbreviated):

"Program Error. The program septerra.exe has encountered a serious problem and needs to close."

The Reason
Genoan from GOG tech support found a reason for this and a workaround.
Razer Synapse 2.0 has conflicts with Wine, well reported elsewhere (see links below).

The Fix
It is a workaround only since it is not perfect, for you will have to make a choice: Synapse or Septerra.
The town is too small for both of them. If you use Synapse, you will have to uninstall it.

This is what Genoan wrote:
"The logs indicate that there is an issue with other software you have installed Razer Synapse 2, please uninstall it, reboot your Mac and check if the game works.
Here are similar issues:"
Cubeworld forum
Wineskin site
Path of Exile forums

My SysSpecs
For comparison purposes in case you need them, these are my Mac's specs:
Model: iMac 21.5 inch, late 2012
Processor: Intel Core i5, 2.7 GHz
Processors: 1
Cores: 4
Memory: 8 GB, 1600 MHz, DDR3
Graphics: NVIDIA GeForce GT 640M 512 MB
Software: OS X 10.8.2

Special Notes
1. The Synapse 2.0 Uninstaller is located inside the Utilities folder on your Mac.
2. Obviously, uninstalling Synapse will prevent you from modifying whatever peripherals you may have, so choose a Profile (if you have many) before you proceede for they will be stuck with it for as long as you keep those drivers uninstalled.

I hope this helps anyone play your game.