It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I double click on the shortcut or on the .exe and nothing happens, at all. I tried running it from the task manager and there are no new processes created when I do it either.
Windows XP Pro, SP3. McAfee security suite, but the firewall is off.
I get no errors, nothing starts, there is no reaction. I have no problem playing other games or running other programs.
1.73 ghz dual core processor
2gigs of ram
intel 945 chipset.
This question / problem has been solved by 81REDimage
Site above is for T&L emulation, you need a much beefier machine then what you would normally need to run these games though. All the instructions to get the games running are on the site.

Basically, pop 3DA into a folder on your desktop, run it in admin mode (if you have vista) and check the box for Software T&L. I got it to run on my laptop with the Intel 945 chipset that way. TBH though, its a terrible graphics chipset. They managed to find room to jam in Pixel Shaders, but then forgot something as basic as HW T&L support. Thankfully, with 3DA you can get a fair few things to work without too much hassle.