It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi there,

when I start the application I see the loading screen and then it stays there for about 10 seconds.
After that it crashes to desktop and shows me a Runtime Error. (attached)

I tried to redownload and reinstall but nothing changes.

Anyone else having this issue?

If I cant fix it I will try to refound it.

Greetings

Anda
Attachments:
crash.jpg (26 Kb)
This question / problem has been solved by anonmeimage
Found the error. Delete galaxy.dll in the game folder. That works. Thanks to the other thread in this forum

Kind regards.

Anda
My problem was a runtime error upon trying to start the game, at 90% loaded the game screen would be replaced
with a small box showing a runtime error message. The curser would also jam up so CTRL-ALT-DEL to bring up the task manager and end program was all I could do. [Win 7]

Removing the Galaxy dll from the game folder got me past that , the game was just downloaded from GOG's site and not through Galaxy. [setup_satellite_reign_2.0.0.3exe]

from the "Cannot Save thread"

hope this helps
cheers anonme

lol you beat me, I should have made a new thread but I was testing the game out at the time.

glad it worked for you
Post edited August 29, 2015 by anonme
Let's hope someone stickies this thread, unless it gets removed in future non-galaxy versions.
avatar
andamar: Found the error. Delete galaxy.dll in the game folder. That works. Thanks to the other thread in this forum

Kind regards.

Anda
Thanks mate. Damn Galaxy, causing troubles when I don't even want to use it, haha.
I don't seem to be affected by this unless GoG have quietly updated the installer (setup_satellite_reign_2.0.0.3.exe)

Galaxy.dll is present in the game folder.

The game launches normally using the shortcut (Launch Satellite Reign)

Windows 10 Pro x64 - I don't have Galaxy installed.
Also had the problem, thanks for the tip... damn that piece of software crap :(
This worked for me.
avatar
andamar: Found the error. Delete galaxy.dll in the game folder. That works. Thanks to the other thread in this forum

Kind regards.

Anda
I have the same problem on GNU/Linux. But I don't have that file (galaxy.dll).

When I try to start the game from a terminal (./start.sh), I get this message:

support/gog_com.shlib: línea 94: 5275 Abortado ./"${bin_32}"

What can I do?