It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I guess I'm at the end of Chapter 1. I throw the switch and zap. But then when the fireworks stop, the cursor doesn't come back and the game just sits there, not completely frozen (F1-12 keys work) but I can't escape out to menu either. Anybody else have this issue? The game seems waaaay too short if that's all there is to it ;)
No posts in this topic were marked as the solution yet. If you can help, add your reply
What OS are you running?
Computer: Pentium 4, 2.79Ghz, 3gig RAM
Video Card: nVidia Geforce 6800
I'm having the same problem, but in chapter 3 when clicking on a door. I'm on WinXP SP3 too, with NVidia Geforce 9800 I think.
I got the same error, the game worked fine but in Chapter 3 I got a crash, I loaded the last save and after that every time I try to interact with an object the cursor will disappear and the game won't continue. It doesn't matter how many times I restart it or load the game it won't work at all.

I had to uninstall it, too bad since I was enjoying it :(