It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Nearly every fix I've found is for the Steam version, such as adding a new settings.dat file with a profile file, which, because the GOG version has it somewhere else, I can't find. Is there any up-to-date fixes for the GOG version?
avatar
DanteC: Nearly every fix I've found is for the Steam version, such as adding a new settings.dat file with a profile file, which, because the GOG version has it somewhere else, I can't find. Is there any up-to-date fixes for the GOG version?
I also bought a copy over the weekend, and I am not able to run it either. I get the following message:

SR2_pc.exe has stopped working
Check online for a solution and close the program
Close the program

My computer is an Intel i7, 16gb, Win7-64, Nvidia GeForce GTX 760.

I've tried various compatibility options, run as admin, etc..... no luck. I've done some searching, but the most I could find was a comment that the game doesn't work on 64 bit machines.

I have a dual boot with Windows 8.1, so I can give it a shot there and see if it works. It's still 64 bit, though.

--------------------------------------------------------------

edit....

Okay, good news. I believe the reason why it isn't working is due to it defaulting in full-screen mode. I managed to find a link on the Steam Forums for a "settings" data file to put into your C:\Users\[profile name]\AppData\Local\THQ\Saints Row 2\

After I did that, I was able to get SR2 working. From there, I had to use my keyboard to move around the menu, but I could then change the video settings to match my desktop. I still have it in Window mode. I've read that you can switch it to full-screen after loading it once, but I think I'll make a backup of that Settings file beforehand.

Here is the page that I found the fix on:

http://forums.steampowered.com/forums/showthread.php?t=1715922
Post edited May 19, 2015 by starrfoxx
That seems to have done it, thanks!
I was using the search function to try to find the THQ folder, and not getting anywhere. Actually going through the path you suggested did the trick though.