It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
there is an issue specific to the gog version of saints row 4 and zonealarm v14 (and possibly other versions)
as soon as the game is launched, a second or so when the first video movie starts to play, nothing happens - black screen and the typical windows 7 apphang window.

i could go on, but here are the absolute facts;

this is a gog specific sr4 issue, since it ONLY happens with the gog version. i have -on the same system- the steam version too, and that works just fine. i have zonealarm running, and the steam sr4 works every time. like it should. no problems. great. run the gog drm free sr4 and it crashes with black screen 1 second after launching when that "crystal" deepsilver logo movie should play.

if i completely exit zonealarm, as in shut it down, the gog sr4 works too, every time and all that. this shows that there is an absolute issue/conflict between zonealarm and the gog version of sr4. the steam sr4 works just fine with za running. so it IS a gog issue, not a sr4 one, per se.

it's not any of the intro BIK videos either, because again the steam version works, and also, i "bypassed" ALL the intro movies by renaming the VIDEOS directory the game has and so it skips all movies but still black screens to nothing.

i also excluded the Saints Row IV.exe via the ZA settings so it would not get virus scanned on launch and a few other things to boot, and still craps out. many will be tempted to say its ZAs fault, but since i have two copies of the game, and one works perfectly alongside ZA and the other (ironically the drm free one, and the supposedly "cleaner" one) doesn't. and this is like on the same system and same hdd and tested within seconds of each other, not weeks/months apart and with maybe slightly different hardware or different drivers or whatever.

and please don't bother with ZA is crap, use something else. keep those comments for others who you think you can manipulate. sr4 steam works and gog sr4 doesn't. its a GOG issue.
fix your corrupted game, gog scammers!!!
Post edited September 04, 2017 by GOGer
avatar
GOGer: fix your corrupted game, gog scammers!!!
How 'bout you use a proper antivirus instead of overly paranoid shit?