It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
As the topic says. I click "Play" in Galaxy, the screen flickers to black, then it goes back to desktop with the usual "SR2_PC.exe has stopped working" message.
Oookaaay, can you give us some more info, like OS, CPU, RAM and Graphics Card?
avatar
Maxvorstadt: Oookaaay, can you give us some more info, like OS, CPU, RAM and Graphics Card?
Windows 7, 16GB Ram, Intel Core i7 3770K, Nvidia 970 GTX 4GB.
Hmm, from what I found in the net, playing in windowed mode could resolve the problem. But don`t take it for granted.
Maybe you should try to start it without galaxy.
Post edited May 11, 2015 by Maxvorstadt
I have tried repairing the installation but it finds nothing wrong, but it does pop up with a Window saying something about the "Nvidia Inspector"?
avatar
Maxvorstadt: Hmm, from what I found in the net, playing in windowed mode could resolve the problem. But don`t take it for granted.
Maybe you should try to start it without galaxy.
I have tried starting it without Galaxy, doesn't work. And I can't even start it, so I can't set it to run Windowed.

Really disappointing for this supposed "optimized for modern PCs" port.
Post edited May 11, 2015 by Nukleon
Hmm, deinstall the game, download the installation files without using Galaxy and install it "by hand".
avatar
Maxvorstadt: Hmm, deinstall the game, download the installation files without using Galaxy and install it "by hand".
I second that as I recentrly tried to install and play Revolver 360 Reactor through Galaxy and it never worked but installing and playing from the "standalone" version worked perfectly
For the old retail and Steam versions, common causes were an activated second display or certain (unnecessary) USB devices. Remove anything not essential for playing. As Maxvorstadt mentioned, forcing windowed mode helped many people, too. You can try a bunch of possible solutions listed on pcgamingwiki.com/wiki/Saints_Row_2
Seems like I got it working, had to delete the previous configuration and start up the game with the -defaults launch option.
Removing the old config file and adding -defaults to the shortcut wasn't enough for me. I had to set compatibility to XP SP3 and disabled visual themes and desktop composition after turning off my second monitor. This is running on Windows 7.

After that it seems to start ok. I created a character and played though the first fight.
edit: wrong thread, apologies :$
Post edited June 18, 2016 by themortal