It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I actually managed to get Sacrifice working at a 1600x1200 resolution using the Windows XP SP3 compatibility settings. However, Next time I tried to boot up the game it crashes with the message "Error Setting Screen Mode". I've tried other compatiblity settings and destop resolutions and I have actually gotten different errors: from the simple "it encountered a problem and had to close" to a complex error message with two error codes. Has anyone solved this problem?

I am using Windows 10 with a Nvidia graphics card. However, I am using the intergrated GPU for Sacrifice.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I had the same Problem using a Geforce GTX 1070 with Windows 10 (using GeForce Game Ready Driver 381.65), and i finally got it working (after lots of testing) with some help from GOG support. Here's what you should do.

Starting the game might work after each of those steps. However you should do them step by step and e.g. dont try out step 2 before you do step 1, and so on

1) Make sure you run the game with admin privileges
2) Reinstall the game and add it as trusted program to your firewall / antivirus settings (maybe set admin privileges again for the game after you reinstalled it)
3) Reinstall DirectX: directx_Jun2010_redist.exe (reason: some files might be damaged. unfortunately the forum doesnt allow me to post a download link)
4) Reset all your 3d graphic settings in NVidia Driver to default value in your nvidia control center (there is a function somewhere to reset all your settings to default)
5) Make sure that Supersampling is off in your graphic settings as well. This option might have a different name like DSR or so
6) If you use two monitors, try to unplug the second one and use only the first
7) In windows legacy components, try installing DirectPlay as well

In addition, what i found out myself:
- Dont manipulate the registry settings. The Full HD fixes you find in many threads and in other sources on the internet are not meant to work with the GOG version. I think GOG made some special optimizations to the original game (i compared some registry settings and graphics behaviour from original CD Version as well as Steam Version, so be careful). The menu may look a little large but ingame its fine. Also, dont go into the options menu, because GOG optimizations might get overwritten and you might not be able to start the game again afterwards.
- Try restarting your PC before starting the game. Even if you just start the game successfully, directly exit it, and try to start it again, it might not work unless you reboot your pc
- A note on localization: The GOG version is only available in english. But if you are in posession of the original CD, you can install the original game and use the files from \data\local subdirectory (e.g. sfx_german.wad) and copy them into your GOG installation. However i did not find an option to change the language ingame, so you might need to rename e.g the old sfx_english.wad into sfx_english.wad.bak and your sfx_german.wad into sfx_english.wad. That works for the units, spells, and so on, the only point where it doesnt work is the campaing voices of the gods... i am still trying to get this to work.

Hope that helps!
Post edited April 22, 2017 by Ruffenuff