It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

Anyone have Sacrifice working with Windows 7 RC?
I've tried a bunch of options including turning pretty much every advanced graphic feature off and a few different compatability settings at the Windows level with no luck...the 1st tutorial runs OK but you can't start the campaign. Sacrifice crashes after about 30 seconds.
I've got an Nvidia 8600GTS and have tried the latest WHQL and Beta nvidia drivers for WIn7.
This question / problem has been solved by zakameimage
I don't know whether this applies for most people, but this worked for me.

I was getting into the game. I could do tutorial 1 and the scenario, but tutorial 2 crashed. I tried a few other fixes, but I don't have nVidia drivers and couldn't do the above solution.

I have a Windows machine that runs 32bit (or whatever it is) though, and so in the settings I changed it from 600x800 16bit to 600x800 32bit. I run Windows 7, I believe, and that seemed to fix it. I'm not a great fixer of things by any regard, but I maybe sort of lucked out and hopefully this'll help someone else too.