It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
This is just a quick summary about the issues I had with the game and how I got rid of them:

1. When I first started playing I got massive graphical glitches which made it completely unplayable. I eventually tried out a suggestion which was about the integrated GPU. Like many people I have both an integrated graphics card and a dedicated one in my notebook. Telling the game to use the dedicated card in the Nvidia Control Panel didn't do anything, but removing the old driver for the integrated card and replacing it with a new one did surprisingly get rid of the glitches.

2. The stuttering: I honestly cannot say for sure what did finally get it down to manageable levels, but in the Control Panel I have turned off Anti-Aliasing and Vsync. I also turned down graphical details to "Low". It's still slower in the towns than out in the wild, but in general it's quite playable now.

3. While trying around with the settings to reduce the stuttering I also played around with the compatibility settings and suddenly I was getting the severely distorted sound again, which hadn't been the case after recently reinstalling it. I'm pretty sure that it was due to having the compatibility set to use Windows 98/ME. Once I put it back to XP the sound issues disappeared.

Hopefully this is of use to somebody.

Edit: Oh, sorry, forgot to say that I'm still running Windows 8.1 on my notebook.
Post edited September 24, 2018 by BurningSheep
I'm running the game on Win8.1 as well and found the follwoing solution for the bad performance.
There is a good thread in the Nox forum wich explains how it works in more detail. So the short version is this:

- Get the Microsoft Application Compatibility Toolkit

- The main tool that is needed is the Compatibility Administrator (32-bit)

- Add the game to the tool as it is described here

- The only compatibility fix that was needed is Win98VersionLie

- Save the database and install the changes

With this the game runs in the menu at 30fps and in the game at 60fps.

Depending of your system there might be other changes needed, but this did it for me, while running the game with all graphic settings on max.

This is a very good tool to make old games run better and if you look at the already installed database, then you might see other GOG games showing up there too. So it seems GOG is using this or a similiar tool as well.
Post edited October 20, 2018 by Schraubchen
Thanks, that sounds promising. I have recently also been having some performance trouble with Restricted Area. Maybe I'll try your suggestion.
I just reinstalled it and tried the Application Compatibility Toolkit. At first I didn't see that you already had found the specific soulution: "Win98VersionLie". But once I tried it, it immediately got rid of the stuttering. Was quite surprised. Thanks a lot! :) Maybe I'll actually be able to play it properly now. I mean, it was kind of playable for me, but only at the cost of some long-term pain so to speak.
Post edited December 25, 2018 by BurningSheep
I put some time into the game the last time, having convinced myself that it runs well enough, but even only playing on medium zoom level the stuttering was still quite bad, so that I gave up on it after having put in 15 hours or so.

I recently gave it another try and after looking around a bit tried the following:

https://pcgamingwiki.com/wiki/Sacred

The measures suggested in the "High resolution rendering"-section are what eventually got rid of the more or less constant stuttering for me. It was pretty severe when fully zoomed out, but even the often bad performance on the medium zoom level did eventually get on my nerves too much. Now it only occasionally stutters, especially in the towns, but it always goes away quickly.
Just tried playing Sacred Gold and I am getting slight animation distortions when it comes to water, banners and signs moving with the wind. Static stuff seem to be unaffected. Anyone else having these issues? Any ideas how to fix it?

Check the attached pictures to get the idea of what I'm talking about! HELP PLEASE! This is so annoying!

EDIT: It seems I can't post any links or pictures, so let me try to describe the problem a bit better. Imagine you have a a location with a blue banner -> every 2-3 seconds the banner switches to a green banner. Imagine you have a sign next to an inn. Every 2-3 seconds the sign just disappears. Water (where it's moving) has these weird square animations. I can post screenshots if anyone can explain how to do it.
Post edited November 17, 2020 by Red_Knight_1981