It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello,

I used to play Sacred Gold back in the old days, but when I revisited it through GoG I was sad to find it would not launch on my modern computer. After some troubleshooting with GoG's support line and some additional personal investigation, I have landed on a solution, so here I am sharing it in case someone has the same issue.

Before I go any further, here is what would happen:
Game is launched, screen goes black (if full screen) or shows a small black window (if windowed mode), then windows' internal crash reporter would show, saying that Sacred stopped working and would list something like this in the expandable details below:

Problem-description:
Problem event name: APPCRASH
Application name: Sacred.exe
Application version: 2.0.2.28
Application timestamp: 452f85c7
Fault module name: D3DIM700.DLL
Fault module version: 6.1.7600.16385
Fault module timestamp: 4a5bd9ab
Exception code: c0000005
Exception offset: 0001ff8e
OS version: 6.1.7601.2.1.0.256.1
Locale ID: 1038
Additional information 1: 9136
Additional information 2: 913666ab9052f14b404613db82087326
Additional information 3: 66cb
Additional information 4: 66cbe0f989c66997f78f972efdc42908

Some things won't match up with yours, such as timestamp and OS version so ignore those, but if you've got a match on multiple lines, this solution may be worth investigating for you (and also if you have no crash but want to run in windowed mode bigger than 1024x768)

I'm not sure if third party software could be endorsed by GoG, so I'm hoping this doesn't break any forum rules.

(I don't have privileges to post links at the moment so you're gonna have to copy and paste and put https before each url, sorry)
The tool that allowed me to run the game is called "DXWnd" which can be found here:
sourceforge.net/projects/dxwnd/
Here is a pastebin of the configuration file I use, although it will have to be manually edited per-user to update the file path and a couple of personal preferences I'll explain below:
pastebin.com/uJTixZVG
Download it or copy and paste into notepad and put it somewhere (preferably DXWnd's exports folder) with a ".dxw" extension, then in DXWnd select the file menu, import and pick the file.

Most settings were left at their default option, but here are the ones that I have changed:

This one is most important, otherwise the game is almost unplayable:
Input -> Cursor Clipper -> ON (instead of default, in which case the cursor could leave the window and cause a number of issues as I'll detail further below)

These ones are merely of preference:

Main -> Position -> Desktop center (instead of X,Y coordinates, centers the game on screen)

Main -> Position -> Window Initial position & size (although it's just personal preference, it is helpful to increase the values in fields "W" and "H" to adjust the window size for users with large desktop resolutions, 1024x768 is default for the game but it will run nicely with values like 2560x1920 on a 4k screen, albeit the framerate might drop drastically)

Video -> Window size & position -> Free (instead of Floating, this prevented the game from resizing itself to the default 1024x768 size while in the main menu, but sadly not ingame)

Input -> Cursor handling -> Release mouse outside window [ticked] (Sometimes DXWnd would lock the cursor inside even when the game is not focused, this option seemed to help for me)

DirectX -> Filtering -> Full Bilinear (instead of ddraw default, this may help increase framerate if the window size is set very large, otherwise ddraw default seems much faster in 1024x768)

DirectX -> Vsync -> ON (instead of default, it increased my fps by a few with "Wait for frequency" option selected just below)


Important notices:

The game must be configured to be full screen through the original launcher, but set to launch in windowed mode in the DXWnd options, otherwise it won't work.

The game seems to have a problem with losing focus (alt-tabbing). Most notable is that when ingame, clicks no longer seem to work on the world (even though the cursor updates to highlight things of importance). However, the menu (accessed by pressing escape) still works, making it possible to create a save file and re-launch the game, although the quit option seems to break, requiring a forced shutdown.
Also worth noting that the window will resize to 1024x768, which is preventable during the main menu with a dxwnd option listed above

Furthermore, the game doesn't seem to draw frames when on a secondary monitor. I've been unable to find a DXWnd flag that helped with this, it may be useful for those on a large primary screen wanting to play on a smaller side monitor due to framerate issues, but it might be out of our control at this point.

If anyone has better luck with alt-tab support or improving framerates with large window sizes, please share it.
I have tried going through my graphics card's (Nvidia) control panel to fiddle with the 3D app settings but I've had no luck there.

It's interesting to note that for me it wasn't necessary to enable windows compatibility mode, specifically run as administrator, disable dpi scaling or disable Nvidia's DSR settings, but they might be worth trying if all else fails.
Post edited September 30, 2017 by poshdan
Does this also fix scaling/stretching issues with non-4:3 resolutions?
It depends.
If you're running full screen it might be up to your monitor to put black bars on the side when it recognizes the 4:3 resolution. Mine doesn't do that so I can't comment on this further.

HOWEVER borderless windowed mode (choosing "desktop" or "desktop work area" in the position part of the configuration), WILL fix the stretching if "keep aspect ratio" is selected. If "hide desktop background" is on, there will be black bars, otherwise you can see your desktop behind the game on either side.
Check your graphics driver settings for the 4:3 on widescreen stretching issue, it's not the monitor that decides the behavior.
Hi,

I tried it as mentioned but in when starting with DXWnd i'm getting the exact same error "Sacred stoped working".
PCGW offers another solution for High-Resolution Rendering
Sacred - PCGamingWiki PCGW - High-resolution rendering

Uses dgVoodoo 2, note it has a newer version on dgVoodoo web site, than the direct link PCGW links to, but they link to the site page above that direct link, it may work better for your hardware, and having more choice is always better.

I've not tried either solution yet, just looking for mods and setup first, as I always do.
Just noticed OP has no clickable link
DxWnd download | SourceForge.net
Post edited August 17, 2019 by UhuruNUru
When I try to start it, I get a Blackscreen and the blue Sacred logo. There is Tellow writing and I do remember one thing saying "The Developer Sounds more like a teacher", but there is a bunch of stuff, then the screen goes black and nothing. Get nothing when I try to bring up the task manager. Sacred plays fine on this thing, which was just upgraded earlier this year. The worst thing is after I shut the computer down ( Hard shut down ) it is difficult to do a restart, or at the least takes a very long time to get to the sign in page. I unistalled it as i have a feeling the game has been hacked and I downloaded the files.