It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
So my main issue right now is that my mouse isn't as snappy as I would like, and so I've died far too often that I would have had I not had mouse acceleration/smoothing on.

Is there any workaround or way to disable it and even give a way for the game to detect native mouse input?

Really liking the game. It's just that the mouse controls are horrid.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Hey, have you tried changing mouse sensitivity in Settings>Gameplay? Maybe this will help.
avatar
muszdinozaura: Hey, have you tried changing mouse sensitivity in Settings>Gameplay? Maybe this will help.
Already resolved it. Just forgot to remove resolve this forum post, so my bad. Thanks anyway!
Great, thanks for the info :)