It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
played just fine, until today, then got this abrupt crash for no apparent reason. The game had been playing fine without the DLC, then today, I loaded the DLC and restarted my PC(after installing the DLC as I usually do) launched the game, and started a new game with the prologue. this happened just when my character and Patty were approaching the cut scene to the first pirate encounter near the temple(prologue objective). yesterday, I played the vanilla game(no DLC) ran fine, got well into the game's main plot, but then I came back home today and installed the DLC and restarted and crash. "Exception the Application terminated abnormally" why? The game worked just fine the last time I had installed them. I had previously installed this game and the DLC before, long ago, and nothing had happened. I have not changed anything on my system. What has happened?

Running
Asus Maximus Extreme VI
Intel Core i7-4770K at 3.50 GHz
32 Gigs system RAM
Nvidia Geforce GTX 780 Ti
Soundblaster ZXR Pro
Windows 7 Ultimate SP1(fully updated all optional as well)
No posts in this topic were marked as the solution yet. If you can help, add your reply
Have the same message. Everything is just fine untill I'm trying to open character's skills. No skill can be seen in the list (I know they must be there, have played game via PS4), if I try to list unseen skeels, I have this error message.

ASUS Z170I Pro Gaming
I5 6600
8GB RAM
Asus GTX 1060 6GB
Windows 10 Pro (updated)

P.S.: have found this post - "Risen 3 No skills/abilities visible in menu - Solution" in Risen Series Discussion. Unfortunatelly, it doesn't help me. Have the same error.

P.P.S.: Actually, thing I mentioned above helped me. Computer restart / log off was necessary to make things work. Now everything is just fine.
Post edited May 13, 2017 by TheVoice