It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello. I'm having quite a few problems with this game and would appreciate any help.
*** My OS is Windows 8.1
*** I have found solutions to a few issues which I will list here.

CURRENT ISSUES:

ISSUE: Areas of the screen without a light source become completely black / dark if the Gamma is low enough.
Turning up the Gamma temporarily alleviates this issue. This seems to be a half-baked implementation of the "Real Time Lighting" system.

ISSUE: Sometimes an area you're in (such as a shop interior) will become darker.
Exiting and re-entering the area seems to temporarily fix this.

ISSUE: On any setting, certain flames (especially wax candle flames) have black rectangles surrounding them
Almost as if to be coupled with the blackness of the games lighting.

ISSUE: The Gamma can be continually altered beyond its intended lowest and highest settings - causing the game to become very dark or very bright.
Pressing OK in the options menu can lower or raise the Gamma and the only way to temporarily fix this is to find the settings that are right for you and then restart the client so you don't have to press OK in the options menu.

ISSUE: I don't notice any difference by turning on "Enhanced 3D Lighting."

FIXED ISSUES:

ISSUE: General crashing
FIX:
+ Open up the Revenant launcher and in the advanced options check "disable fast surface locks"

ISSUE: Crashing due to "running out of Z buffer"
FIX:
+ Open up the Revenant launcher and in the advanced options check "disable Z buffering"

ISSUE: All of the text has purple shadowing making it hard to read.
FIX:
+ Open up the Revenant launcher and in the advanced options check "forced software rendering"

ISSUE: The mouse icon disappears.
FIX:
+ Open "revenant.ini" located in GOG Games\Revenant.
+ Under the [Options] section, make sure "Software3D=Yes"

ISSUE: Cannot enable "Enhanced 3D Lighting"
FIX: (although it seems to do nothing / cause issues .. here's how to enable it)
+ Open "revenant.ini" located in GOG Games\Revenant.
+ Under the [Lighting] section make sure "EnhancedLighting=Yes"
+ Under the [Options] section make sure "EnhancedLighting=Yes"
+ Launch Revenant and make sure Enhanced 3D Lighting is enabled in the options.

NOTE: It is not advised to enable "Real Time Lighting" or "Enhanced 3D Lighting" as they seem to cause problems.
Post edited March 24, 2018 by buddykid
No posts in this topic were marked as the solution yet. If you can help, add your reply