It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

*Disableing everything in game launcher fixed my issues

Hi. I've been having some trouble with the game since my purchase yesterday.
First off the game runs smoothly after a fresh installment, but after some time (about the time i get lvl 2) the game freezes.
When I reboot the game there is no mouse cursor but I can clearly still use it even tho its invisible.
I forced myself into my most recent save and there is some issues as my inventory is invisible aswell as lockes picture in the top left corner - still no mouse cursor.
From the brief time I was ingame with this I saw no other issues, movement and mobs were still there.

I did google to find an out and non of these worked:

- Launch properties (see picture)
- Display pointer trails were never checked (see picture)
- Reinstallment. It only took me as far as it worked perfectly again untill ca lvl 2 again.

Send help please

Windows 10
Graphics: GEFORCE® GTX 1080 Ti
Processor: Intel Core i7 4790K 4 GHz 8MB
Motherboard: ASUS Z97-A
Screen: ASUS 24" VG248QE
Post edited March 31, 2018 by gogharlek
No posts in this topic were marked as the solution yet. If you can help, add your reply