It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hey good people,

Long story short you have to use dgVoodoo wrapper to make it happen.

1. Download dgVoodoo 2.55.4.1 (for regular usage (released: 01.03.2019))

2. Copy all the files from <MS> directory from the dgVoodoo archive to the game dir where <Revenant.exe> is located.

3. Edit <revenant.ini> file to enable Direct3D renderer:
- Software3D=No

4. Run the game
- Mouse cursor will work properly
- You can turn on Enhanced 3D lighting

Additional improvements:

1. Edit <revenant.ini> file to enable additional settings:

Under [Lighting] section:
- EnhancedLighting=Yes

Under [Launcher] section:
- PreloadSize=7
- CacheSize=24
- Detail=5

2. Use ReShade to emulate CRT look. This will hide jaggies and hard pixelation of the game.
- download ReShade (Version 4.3.0 was released on May 26th 2019)

- Install it into the game dir where <revenant.exe> is located using DX10+ option and download AdvancedCRT shader when promted. You don't have to download all of the available shaders in the list.

- Run the game and hit <Home> button to edit your ReShade settings.
Adjust <resolution> setting to your taste. I set it to 2.800.

- You may want to increase ingame gamma to MAX as the game turn a bit dark when CRT shader is enabled.
- Try to tweak with shader's Brightness option to compansate darkness as well.

3. You can disable dgVoodoo logo using <dgVoodooCpl.exe> file form its archive. Just copy it to the game dir and run. Go to the DirectX tab and uncheck <dgVoodoo Watermark> setting.
Post edited July 08, 2019 by GreatDragona
Thanks for the tip, friend!

That helped me a lot. Now i can play this awesome game one more time just like the first (which means A LOT OF LIGHT EFFECTS and advances magic effects). But still, there is another side of the coin: enabling enchansed light and real-time light makes this game choke with top-low fps i've ever seen - like i'm trying to play it back in 2000 with my old PC.

Is there any chance to fix this?
Hey man, I followed the instructions, but my game now runs in a small window at the top left of my screen, anyway to get it to go full screen with these awesome effects?

Thanks
avatar
2ylite: Hey man, I followed the instructions, but my game now runs in a small window at the top left of my screen, anyway to get it to go full screen with these awesome effects?

Thanks
Hey, friend, i've met the same problem, but was able to solve it simply by clicking game's icon several times on windows' panel. It forced the game to roll fullscreen.
Also, try to run "Revenant" via another .exe (means if it's "lancher.exe" - try "revenant.exe" e.c.t)
avatar
2ylite: Hey man, I followed the instructions, but my game now runs in a small window at the top left of my screen, anyway to get it to go full screen with these awesome effects?

Thanks
Fullscreen mode should be handled by dgVoodoo.
Doublecheck you settings in "Appearance" section under "General" tab. It should be set to "Full Screen". I have scaling mode set to "Unspecified" but fill free to play around with it.

You may also try to resize game resolution by dgVoodo.
Go to "DirectX" tab and change Resolution from "Unspecified" (default) to "Max ISF"

Also check scaling mode in your monitor settings. I have it set to "Fill preserving aspect ratio". But you can do it through a control panel of your video card.
- for Nvidia: Display -> Adjust desktop size and position

@ShellDNMS
Doublecheck if you have any "Compatibility mode" turned off for <Revenant.exe> in its properties. I had the same issue with performance as well until I turned that off. Other settings like "Reduced color mode, run in 640x480 etc." has no effect on the game as I'm aware.

The game runs at 25 fps locked through dgVoodo and Reshade enabled.
Post edited July 08, 2019 by GreatDragona
Hey Great Dragona

I played around a little bit to no avail but then tried something completely different

by enabling d3d directly through the Revenant launcher and it worked like a jiffy popcorn door knob charm!

No need for all those extra programs it seems,

Enjoying this great game!

Freedom!
avatar
2ylite: Hey Great Dragona

I played around a little bit to no avail but then tried something completely different

by enabling d3d directly through the Revenant launcher and it worked like a jiffy popcorn door knob charm!

No need for all those extra programs it seems,

Enjoying this great game!

Freedom!
Yeah I saw your message in other thread. I'm glad you could make it. However it seems that solution has its drawbacks as well. Not everyone can select "DirectDraw HAL" in the launcher. It seems this option is completely missing for newer builds of Win10. Or that option is available only for AMD's graphic cards users for some reason. Please correct me if I'm wrong.
Post edited July 08, 2019 by GreatDragona
Actually brother all I did was follow the instructions of checkboxing all the disable bla bla bla options

its still set to primary driver in the top

its great for what it does, makes the game look a little better, lucky that we can do that at this point.

such a great game, happy I picked it up again after all this time, I just never was able to get into it much back in the day for some reason, I think it used to crash on me alot or something.


in a total side note I made chicken and waffles today.

Cowabunga!
avatar
2ylite: Actually brother all I did was follow the instructions of checkboxing all the disable bla bla bla options

its still set to primary driver in the top
Well if you checked all those 'Disable' checkboxes and didn't have DDERR message pop up you are a lucky guy.
But that doesn't make the game run in D3D.
You still can't enable enchanced 3D lighting and your avatar model is not animated, isn't it?
Post edited July 08, 2019 by GreatDragona
Got it all to work brother enhanced lighting and D3d, the way I was able to validate this is becuase when I used the voodoo thing it gave the effects but ran it windowed, then when I deleted that and just checked the disabled boxes, I got the same result but full screen.

I will no longer be answering any more questions on this matter.



This message will self destruct in 15 seconds.
Here is the video showing how the game looks with all bells and whistles enabled:
youtu.be/lhilbjUPk_U
Post edited July 08, 2019 by GreatDragona
Thank you for the tutorial! Yes, I agree, this game is quite finicky about it's settings.

Just wanted to add that you really need to remove the compatibility setting from the main .exe if you're running the game with dgVoodoo. If you don't then game performance will be bad and there won't be a mouse cursor (at least for me).

Also it seems that most of the other crashes (crash at startup and missing .cpp) are somehow related to the 8.3 naming convention (which is disabled by default on modern Windows setups). My game wouldn't even start in it's default install location. I'll try testing this out in the following days.