It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Just bought this in the sale after remembering it from an old PC Gamer demo disc.

Tried clicking play. Tried running as Administrator. Tried playing around and switching between 3Dfx and Direct3D versions.

Running Win8.1 on a cheap laptop, if that matters. Anyone else solved this problem?
At game download page there's a message from GOG:
In Requiem: Avenging Angel, there are two shortcuts provided to launch the game, one for 3dfx nglide (the default, and recommended shortcut), and one for Direct3D. For users that wish to use Direct3D, please note that there is a critical bug present in this version of the title. For further information, please visit here (link follows):
But this link doesn't work :(
Please fix it GOG.
Have you tried to change the desktop resolution? Run it on compatibility mode? Run a older version of direct x?
Post edited August 19, 2017 by Danyboi
I know this is an old post, but here is how to run it in Windows 10 (with a glitchy menu, but any resolution):

1. First install the game normally. Run it via GOG's shortcuts and set up your keys, etc. Do it before the following steps because after step 3 the menu will not render properly.
2. Go to to download dgVoodoo2. Ignore any virus warnings, they are false positives.
3. Extract the archive somewhere (e.g. C:\Apps\dgVoodoo2). From inside the archive *copy* all the DLLs from *both* the "MS" and the "3DFX" folders to the game's folder (e.g. C:\GOG Games\Requiem - Avenging Angel). Replace any existing DLLs.
4. Open the dgVoodoo2 control panel (the .exe in the archive) and from the Glide tab select Voodoo 2, set the onboard RAM to 12MB, memory size to 4096kB, TMUs to 2 and uncheck the "3Dfx watermark". Set the resolution to what you want (but 4:3 resolutions are recommended - note that you can set up custom resolutions in both Nvidia and AMD control panels so you can use a custom resolution that is vertically the same as your native resolution and horizontally something that fits 4:3 and then configure the GPU or monitor to center the image so you get pixel perfect output).
5. Run the game using the 3DFX.EXE program. The menu will be all white and washed out and the mouse cursor will not show at the proper place (if it helps, the game thinks that the cursor is at the top left 640x480 area but it renders in the resolution you used). Move the mouse around until you manage to focus "single player" and click. Similarly use the "New game" or "Load game" options.
6. Once inside the game, it should render at the resolution you picked in dgVoodoo2's control panel. The FOV is a bit low, so press Enter to open the console and type -FOV70 (or whatever you want, i prefer this value - note that lower values actually increase the FOV!).

From now on the game should work fine. However i find the mouse a bit laggy so i also disable vsync from dgVoodoo2's control panel and use RivaTuner Statistics Server to force a 60fps limit (physics might break if you do not do that, e.g. you might be unable to climb ladders and the mouse might be a bit choppy/glitchy). Note that in recent versions of RTSS you must disable the "Custom Direct3D support" option, otherwise you'll get a "Not enough memory" error message when starting the game.
Tried the aforementioned dgVoodoo2 solution, to no avail :(
still can't launch the game with my Win7
Post edited July 24, 2019 by cuaca_baik
You can use DDrawCompat instead of dgVoodoo.

There's also this patch that might help.

On some videocards you have to disable the intro by deleting SMACKW32.DLL from the "movies" folder.

You might have to try to start both D3D.exe and 3DFX.exe multiple times to get the game to run.
Post edited July 24, 2019 by teleguy