It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
Regalia - Royal Edition

Changelog for Update 1.2a (added 06 June 2018):

We are excited to announce that the second DLC pack for Regalia: Of Men and Monarchs is now available!
A lot of exciting content awaits you in Paragons and Pajamas including new playable characters, new story beats, and more.

Here's a complete list of new stuff to experience:
- A new playable character - Quinn. Aligned with Armelisse and sent by the Duchess herself to oversee Kay's progress, she is a tanky warrior capable of withstanding a lot of damage, taunting enemies and manipulating shields around the battlefield.
- A new playable duo of characters - Yusuf & Berius. Superficially aligned with Minwe, but their quest for knowledge rises above borders. They are our most unique combat characters yet, with mechanics centered around sleeping (!), genie summoning, and area denial.
- A new pair of diplomacy factions to interact with - the Merchant Princedoms of Minwe and the Duchy of Armelisse. They come complete with new diplomacy missives and rewards.
- Two new personal bonds to pursue - one for each of the new characters.
- New weapons to find and craft.
- New cutscenes with new voiced lines.
- In addition to the DLC, we are also deploying a new major new feature which is available to everyone for free:
- New RNG system - say goodbye to the frustratingly long chains of misses. The new mechanic tracks your dice rolls and adjusts them slightly if you keep rolling below average results. This should result in a much more consistent, smooth, and ultimately less tedious battles.

Finally, there's a couple of small bugfixes and balancing passes for the base game, including the final fix for Esther's bugged personal quest requirement.
Cheers!
DLC is broken. Activation quests do not load.
avatar
Ogedei: DLC is broken. Activation quests do not load.
Hi! This happened to me too. 100% Verified that the activation quests do not load

Tests done:

- Tried loading previous save to try (Quests did not activate)
- Tried restarting the game from the beginning (Quests did not activate)
- Cycled through whole time line of when the quests should activate according to developer (no quest activation)
- Uninstall --> Reinstall (no change)

thank you!
Recent Hotfix patch just fixed this now. :)
Which version is Linux version? It says 8.05.2018, versioning kinda unrelated to Win\Mac version