It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

How can I disable the hud in Red Faction 2?

There's no menu option, keyboard shortcuts that disable it, or a console to enter commands.

However, there is a file called rf2_config.ini with various commands suggesting it's possible.

I tried all of these, but none of them worked;

Hud_head = 0
Hud = 0
Drawhud = 0
Draw_hud = 0
Show_hud = 0
Showhud = 0

I only tried the hud_head command because of this command in that file:

Changing that option doesn't change the size of the hud though. I guess it selects the size of the texture file to use for the hud.

Does anyone know of any command that works? I'm also open to mods.

Edit: I found references when looking through the rf2.exe file that mention a developer's debug menu. If someone knows how to enable that and then bring it up in game, that could be the solution. It mentions being able to toggle the hud on / off.
Post edited April 26, 2020 by hudfreegamer
I came up with a work-a-round. I created a custom resolution in the Nvidia Control Panel of 1920x1920. Then, I edited the game's config file and set it to that resolution.

Then, when I run the game it renders it in a square with the hud up higher. I move the mouse to shift what's visible and make the hud move off screen but keep the crosshair centered.