It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey guys. Picked up Red Baron during the sale and put about 5 hours into it when the Joystick I bought stopped working with it.

It's not the Joystick as I calibrated it in Windows and all of the buttons and what not seem to interface perfectly.

Any suggestions on how to fix the problem? I've tried reinstalling already.

Joystick Logitech Extremepro3D

Computer: Asus - Windows 10
No posts in this topic were marked as the solution yet. If you can help, add your reply
Have you tested both Red Baron and Red Baron 3D ?
bthanse: Have you tested both Red Baron and Red Baron 3D ?
No I've only played 3D.

EDIT: Downloaded and Tried both. Not working on either.
Post edited July 13, 2016 by DenimDave
Start your Logitech profiler

Give this a try after you get the assignments set.
On your Log Profiler Click "Options" Tab
"Global Profiler Settings"
Check "Apply persistent profile"

Should work for any RB3d install now!