It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hey all!

We've discovered that our previous Galaxy build might not have properly created registry entries, which are used to recognize if and which version of Rebel Galaxy you have installed. To prevent any issue from occuring, please ensure that you only update using the original installation method - i.e. if you installed via Galaxy, only update through Galaxy, and if you installed via the backup installers, please only use the downloadable patch installer.

Apologies for any inconvenience caused!

B0SC0