It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
So I finally got Rayman to work on Linux.

My folder structure is :

/rayman.pc
../GAMES
..../Music
..../RayFan
..../RayKit
..../Rayman
....game.gog
....game.ins
..dosbox.bat

And my dosbox.bat contains :

cd games
imgmount d "game.ins" -t iso -fs iso
cd rayman
rayman

I did not have to change anything in game.ins
I just removed all the .conf files.


What is strange is that if I replace :

cd games
imgmount d "game.ins" -t iso -fs iso

by

imgmount d "GAMES\game.ins" -t iso -fs iso
or imgmount d "GAMES/game.ins" -t iso -fs iso
or imgmount d "c:\GAMES/game.ins" -t iso -fs iso

The image cannot load. The .ins file is well referenced but it can't be loaded ...
Post edited May 17, 2019 by Dasha66
Hello,

this is my recipe for play this game on Linux with native Dosbox:
1) install the game with Wine or extract the setup with innoextract
2) If not already there, move the 2 Dosbox conf files in the main game folder:
dosboxRayman.conf and dosboxRayman_single.conf
3) open a terminal inside this path folder
4) type this commands:
Windows uses backslash for path and Linux slash. For this reason, Dosbox WIndows config are not Linux immediately compatible. This commands will replace backslash by slash for audio tracks and drives paths:
sed -i 's=Music\\=Music/=g' game.ins
sed -i 's=..\\==g' dosboxRayman_single.conf
this commands will change some dosbox options to avoid sound parasite and better speed:
sed -i 's/output=overlay/output=opengl/g' dosboxRayman.conf
sed -i 's/core=normal/core=auto/g' dosboxRayman.conf
sed -i 's/cycles=80000/cycles=auto/g' dosboxRayman.conf

Hope this help.
Post edited October 23, 2019 by legluondunet