It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
So I just installed Rayman 2 on my laptop but there's a problem that's really bugging me.
At first, the game was running too fast. I fiddled around and noticed that turning off vsync was the solution to that, BUT now there's some terrible screentearing instead. I can't play it like this.

Does anyone have any idea of how to fix the screentearing without having the game running too fast?
Post edited May 01, 2015 by OmegaMetroid93
No posts in this topic were marked as the solution yet. If you can help, add your reply
Strange, I literally just helped someone else with this (unless you are the same person). Anyway, go into nGlide settings in the Rayman 2 folder of the start menu and change the refresh rate to 120 Hz, and make sure to keep vsync on, and you should be good to go.
avatar
RibShark: Strange, I literally just helped someone else with this (unless you are the same person). Anyway, go into nGlide settings in the Rayman 2 folder of the start menu and change the refresh rate to 120 Hz, and make sure to keep vsync on, and you should be good to go.
Thanks dude, the 120Hz refresh rate solved my speedup issue! (I get some stuttering from time to time tho)
Post edited December 14, 2017 by YayaTourette
this might be dead but aint not working for me