It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
funny enought in full screen mode the cutscene bars stay so yeah, all the other versions dont have that problem (tried them on some emu) and gotta say the gamecube rayman 3 plus hd texture pack is probably the best u can get for rayman.
Post edited August 20, 2019 by Seragin
avatar
FunkyFinzy: I installed the game and installed the patch and trying to launch the game, either via GOG or through the .exe does nothing. Trying to run them as admin also does nothing. The config .exes won't launch either. Any ideas? Using Windows 10 64 bit.
Same here. Have tried a bunch of suggested fixes, but no dice... neither EXE will launch.

Edit: Right after posting this, I think I figured it out! Figures!

Here's what seems to have worked for me:

1. I downloaded a fresh install of Rayman 3 from GOG.
2. Before installing Better Rayman 3, I ran Rayman3.exe as an administrator, saved a configuration and confirmed that the program opened as intended.
3. I downloaded the Better Rayman 3 installer and ran it as an administrator. (Every post I saw online talked about running the config and/or game as administrator, not the installer).
4. Once the installer finished, I ran BR3_Config.exe as an administrator and it worked.
5. Finally, running Rayman3.exe as an administrator worked.

For some reason, I had to do those last two steps a couple of times in a row for all my chosen settings to take effect. But now it seems to work as intended (Windows 10 64-bit).
Post edited August 25, 2019 by tylersticka
I also get letterboxed gameplay. Any way to fix it??
Hello
I've only tested the game shortly but everything except the right stick seems to work properly.

The only other problem I have is that I can't change the game language, it stays in english no matter what I do:
I've tried running BR3_Config.exe as admin, running R3_Setup_DX8.exe as admin, changing the language.ini file, nothing seems to work.

I guess I'll try to do a clean install and change the laguage before installing the patch and see how it goes.
Post edited March 31, 2020 by Eyle
avatar
Thechugg: I also get letterboxed gameplay. Any way to fix it??
It fixes for me weirdly enough when I plug my controller in and out
Post edited July 18, 2020 by A_Br0do