It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

× video of the process from a fresh install

Fullscreen- tbh don't use fullscreen, use windowed or borderless you'll have less issues
download the ddraw linked here
direct ddraw link
press Releases and get the first one you see
extract it to the roguespear.exe location
The compatibility settings I use are: run as windows 98,16bit,run as admin
go to the registry mine was located here
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Red Storm Entertainment\Rogue Spear

change Fullscreen to TRUE
this should allow you to launch in fullscreen and select your desired resolution from the video screen
the downside to this is the game loads slowly when loading into a map (20seconds maybe?)

do the above up to the registry step
fullscreen FALSE
VideoResolution 1600x900

borderless windowed
Set the game to run in windowed mentioned above
download this Borderless-Gaming
launch the program,launch RS, alt tab back to the program and find RS in list of applications and press the right arrow and move it over to favorites.
alt tab back to RS and if it doesn't work straight away just relaunch the game
from there go to the graphics menu and change to resolution you want to use

doing this will allow you have fast loads and be fullscreen when you play. the menu sections and all that will still be small

unlike R6 you cant do incremental changes but RS doesn't crash when out of bounds at max resolution. in window mode you won't have slow loading

cap your frame rate again due to AI issues and it should help the slow 3rd person camera
I hope this helps you, if not show me what errors show up in the rommel.log located in the roguespear.exe folder and maybe i can help fix the issue
Post edited November 26, 2019 by volcanotron