It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi all.

I bought Railway Empire time ago and have been playing fine since then. Also, I bought all the dlc's individually.

This is the problem: I recently updated my old W7 box (installing new cpu, motherboard, ddr4 ram, ssd, a high end setup now) so I decided to install W10 Pro 64b from scratch after that. All worked fine. I had my GOG library folder in another hard disk, and Galaxy recognized most of the games as installed (almost all of them, in fact) and the games are working.

But not Railway Empire. I've not receiving any error message, nor warning dialog, ... anything. I tried to start it from command line, but no response. Always the same: the intro video, and then when it seems to be starting the game, closes. It didn't show the main menu. Simply closes. That's all.

I searched about adding a global variable related to a problem with gen 10/11 intel cpus, didn't work. Also verifying/repairing files. All was fine, and didn't work. Also uninstalling and installing all (game/dlcs) from scratch. The same result. Game closes without any message and never starts.

I have no more ideas about what to do. Please, help needed.

Thanks in advance.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Current specs, if it helps:

Intel i5-11600
MB Asus Tuf Gaming B560M Plus
GPU Gigabyte GTX 1060 6GB
SSD Samsung 970 EVO Plus
HD Toshiba 2TB 72000rpm
Windows 10 Pro 64bits (21H1, up to date)

GOG Galaxy v2.0.40 (16 july)
Game and 8 dlcs version

Any advice'll be appreciated
Post edited July 27, 2021 by Gromenauer
Solved. XD

It was the damn galaxypeer64.dll library from GOG Galaxy.

Path to file: C:\ProgramData\\Galaxy\redists\peer\msvc-18\GalaxyPeer64.dll

Tried different ways, but only deleting this file solved this f****ng error. No cloud saving in my case, so no need to maintain it. And Railway EMpire is now runnig at last!

Thanks to the Event viewer (eventvwr.exe) for giving the clue. Nice utility.

ps/ By the way, Gog and Gaming Minds customer support sucks a little. Thanks for nothing, beyond lot of weeks with an iced game.
Post edited September 03, 2021 by Gromenauer