It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello everyone!

I know this game is no longer being sold by GOG but i'm having a weird technical problem and maybe someone here can help me out.

I haven't been able to launch the LAN multiplayer mode of Grid on both my Windows 10 x64 computers (a recent desktop and a laptop both with build PRO 1803). Game works fine, everything else works perfectly, the sound, the higher resolutions, compatibility modes etc. The game runs on all kinds of configurations, except that LAN multiplayer part, which was exactly what i needed from it (i'm trying to set up a LAN with my son). Always returns that annoying SESSION ERROR: Unable to connect to session, no matter what I do (and i tried LOTS of different things these last two days). I probably tried everything i could remember, from disconnecting the firewall and antivirus, skype, utorrent, etc to applying a reg text file from another computer installation on Windows Vista 32. I tried installing directx 9.0c and enabling directplay on windows 10, adding the grid.exe file to dep exceptions, disabling explorer.exe, installing to a different path and disk, leaving just one adapter enabled, etc... NOTHING seems to work. I even tried to copy the lan settings from the working Vista 32 computer but it didn't help. Messing with my router also didn't help nor disabling most services for my LAN adapter.
Now I know this game is perfectly capable of working on win10 (i tried it on some friend's pc and it worked) but i'm wondering what is preventing it from finding/setting up a LAN on my rigs. I don't really wanna set up a virtual online connection to emulate the old closed down servers, i'm just trying to make the LAN settings work.
Anyone will help?

So, to anyone who might have this issue, i finally managed to find a solution!!!
Problem was not on Windows 10, apparently a part of a program i had installed was causing this.
CyberLink PowerDVD 11 version 11.0.1719.51 installs something called PowerDVD RC Service to the windows startup tasks and as soon as i disabled it from startting, GRID ran just fine and was able to join and host LAN games.
I'm not sure if newer versions of PowerDVD also cause this problem but i'm posting my solution in case it helps others.
Thank you so much to everybody who tried to help me out.
Post edited October 16, 2018 by DoutorHouse