It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi - I originally started QFG1 as a Fighter with Magic abilities, became a Paladin at the end of QFG2, and played on through the series to the beginning of QFG5. I was really excited to play Dragon Fire -- I'd had the original collection, which didn't include Dragon Fire, as a kid -- but when I imported my character I noticed several spells which I'd had since QFG1 were missing. Off the top of my head, I see Open, Trigger, Fetch, and Calm are all gone. Is there a reason for this? I've tried updating to 1.2, but it didn't seem to make a difference. All I can think is is it's either a bug or, since I originally was a Fighter instead of a Wizard, the game thinks I shouldn't have these spells. I'll try to attach screenshots of my spells at the end of QFG4 and the beginning of QFG5.
Attachments:
qfg4.jpg (487 Kb)
qfg5.jpg (97 Kb)
Post edited September 26, 2017 by kpeterson413
This question / problem has been solved by Darvinimage
EDIT: Sorry, I didn't see your attached images. Give me a moment to rework my response.

That's definitely a new one for me - I've lost spells going into QFG4 before (in fact, at one point, I had my Paladin Heal spell changed into a completely different spell, which necessitated a re-import) but I've never seen that happen, myself.

I would suggest going back to QFG4 and maybe try throwing those spells around for a bit to change their skill value, and try exporting again. That might result in the spells transferring properly.

Though in my opinion, as you're a paladin, you'll often run into the problem of having to unequip your sword every time you want to cast a wizard spell. Anything you could use the Open spell for you can force open, and for traps, you'll have a power that'll transfer any elemental damage you take to stamina instead - Trigger would also be useful for this, but it's not necessary. Fetch is utterly useless in 5, being little more than a gimmick spell, and Paladins get a Calm-like spell that completely invalidates the need for the Calm spell itself.

For the record, neither 4 nor 5 have any idea what you started 1 as. That information gets lost the moment you change your class, whether in 3's import option or by successfully becoming a paladin. All 4 and 5 know is that you're a Paladin, and you have the Magic Skill and those spells. That's it.
Post edited September 26, 2017 by Zachski
I've encountered this bug before. The problem happens when your imported character is missing spells that a newly created character would normally have. Rather than just adding the spell to your list of spells known, it overrwites your existing spells! In my case I was missing the Lightning Bolt spell, so when I reached QFG5 it added Lightning Bolt... and overwrote the Trigger spell.

The only solution is to use a save editor to fix your character after importing it.
Thanks all - it looks like the common factor among my missing spells is that their skill (at time of export from QFG4) is less than 50, which apparently is interpreted by QFG5 as never having learned the spell at all (yeah, I'm a Paladin, I don't exercise my magic as much as I should.)

For some reason I was having problems with the import file editors I found, so I took it as a personal challenge to write a new one. Finally got it working - C++ source is here if anyone's interested: pastebin.com/TWKdPbej . This confirmed my theory - with the Open skill set to 49, I don't have the spell when I import into QFG5. Set it to 50 and, hey, there it is.

I think I'm going to load a few saves back, before entering the Dark One's cave, and try to pump everything up to at least 50. For some reason that feels less dirty than using an editor. Thanks again!
Post edited October 03, 2017 by kpeterson413