It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I've seen a lot of questions (not just on GOG.com) about a) running QFG5 in a window and b) changing the resolution beyond 640x480. Running it in a window isn't that tricky, there are many methods to do this -- even more trivial if you run Windows games in WINE and not natively. But actually changing the resolution is trickier, as it is hard-coded to 640x480 in the game engine. Thankfully, you can accomplish both a. and b. with one fairly easy step. I haven't seen this covered anywhere else on the Internet, so thought I'd post it here in the hope it is helpful to somebody.

There's a freeware app for Windows called DXWnd that is designed primarily to run legacy games at any resolution you desire.

1) Download and install DXWnd (may be found on SourceForge).
1a) If you're running QFG5 in WINE, just install DXWnd in the same prefix where you've installed QFG5. It works fine in WINE (tested with WINE 2.17)
2) Add an entry for QFG5, setting the Path (i.e. the directory where the game is installed) and Launch (the path to the executable that starts the game) entries under the Main tab.
3) Under Position from the Main tab, make sure to enable "Keep aspect ratio", then set the W (width) and H (height) you want to run the game with.
3a) Set the Width and Height to a power of 2 for best results, especially if using the "nearest neighbor" 2x filter DXWnd uses by default. For example, 640x480 might become 1280x960, 1920x1440, or whatever 4:3 aspect ratio best fits your monitor.
3b) Optional: Enable "Run in Window" from the Generic section if you don't want the program to try to run fullscreen.
4) Optional: If you don't like the default "pixelated" 2x nearest-neighbor look, you can configure various other filtering tweaks and settings. There are 17 tabs in total packed full of all kinds of tuneables; this is an exercise left to the industrious reader.
5) From now on, launch QFG5 from the link you've created in DXWnd rather than directly.

This will also work for many other early Windows games which don't allow resolution changes or running windowed.

Enjoy,
-Chris
Attachments:
Post edited September 22, 2017 by cwadge
It's not working for me - the game continues to force its launch into full screen mode despite my best efforts. And yes, I'm running it from DXWnd, not the game's default executable.

https://puu.sh/xHiDV/6bb73e999f.png
https://puu.sh/xHiFj/fee22908c5.png
https://puu.sh/xHiFR/23fe4f1169.png

These are my settings

EDIT: Okay, I figured out what went wrong.

"Path (i.e. the directory where the game is installed)"

I took this part too literally. It shouldn't lead to the directory, it should lead to the executable.

So near as I can tell, Path and Launch should lead to the exact same file.

EDIT 2:

It seems like the game performs worse in windowed mode - it feels like it runs less smoothly than it does in full screen mode. Is there a way to fix this, or is this just one of those "You'll have to live with it" moments?
Post edited September 24, 2017 by Zachski
avatar
Zachski: It seems like the game performs worse in windowed mode - it feels like it runs less smoothly than it does in full screen mode. Is there a way to fix this, or is this just one of those "You'll have to live with it" moments?
There are way too many tuneables in DXWnd for me to say, especially since it never slowed down at all for me no matter which settings I chose. I am running it in WINE, which may make some difference (like rendering DDraw surfaces in OpenGL), and I have a PC that's ageing at this point but still fairly capable...

AMD FX(tm)-8350 Eight-Core Processor
NVIDIA GTX 770
16GB RAM

Unfortunately the limited docs I was able to find on DXWnd suck pretty badly, so you're probably in trial and error territory on this one.
Running this game under DXWnd natively fixes the Win 10 memory exception, just like running in Win 8 compatibility mode does. And unlike this compatibility mode, DXWnd stops the game from forcibly fullscreening onto my HDMI 1080p 16:9 TV, instead letting me push the game onto my DVI-D 1280x1024 4:3 monitor. (Not only does V try to stretch itself to widescreen like some Goon was pushing the buttons, the lower PPI makes QFG5 look better than on my TV, too)

But, I've run into a separate issue - under the simple, default settings, any FMV playback causes the game to hang (not crash) and close the window upon exit. The FMV itself plays fine. I'll look into this, and if I find a good fix, I'll post it up, because more people will no doubt be in my shoes.
avatar
N7Kopper: Running this game under DXWnd natively fixes the Win 10 memory exception, just like running in Win 8 compatibility mode does. And unlike this compatibility mode, DXWnd stops the game from forcibly fullscreening onto my HDMI 1080p 16:9 TV, instead letting me push the game onto my DVI-D 1280x1024 4:3 monitor. (Not only does V try to stretch itself to widescreen like some Goon was pushing the buttons, the lower PPI makes QFG5 look better than on my TV, too)

But, I've run into a separate issue - under the simple, default settings, any FMV playback causes the game to hang (not crash) and close the window upon exit. The FMV itself plays fine. I'll look into this, and if I find a good fix, I'll post it up, because more people will no doubt be in my shoes.
You're absolutely right, and I would love to see a fix for this. When doing my speedruns of QFG5, I ran into this problem, because I would have loved to run the game in a Window which makes streaming SO much easier. The Quicktime format they used for movies does not like DxWnd, and I've gotten it to the exact settings you have, with one step beyond. I can get the game to rehook after the movie, but the mouse hooks at a strange location way off the screen, and all actions cause the main character to attempt to move to where the mouse is hooked which is way off of the screen. :/ Couldn't get it to work beyond this.