It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Heya. I'm trying to run Quake 2 on a Windows 8.1 tablet(full win ver) that has a 512mb video memory from the InteHD 520 in it. The tabet has1 gb of RAM ad pocessor should be enough.But for some reason it won't launch. Iom also runing this on an xternal card so not sure if it has anything to do with it. Anyone else encountered this or might now wh it refuses to launch?
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
kaibamon: Heya. I'm trying to run Quake 2 on a Windows 8.1 tablet(full win ver) that has a 512mb video memory from the InteHD 520 in it. The tabet has1 gb of RAM ad pocessor should be enough.But for some reason it won't launch. Iom also runing this on an xternal card so not sure if it has anything to do with it. Anyone else encountered this or might now wh it refuses to launch?
Hi you might want to try the Quake 2 3.24 patch from http://leray.proboards.com/thread/3258/quake2-24-unofficial-patch-released
If you also go to the baseq2 folder in the Quake II install folder you can copy the config file and rename it Autoexec. Delete the contents and replace with the following lines
set r_mode "-1"
set r_customwidth "1920"
set r_customheight "1080"
set cl_widescreen_fov "0"
set fov "90"
This allows widescreen at 1920 x 1080 res
Post edited August 18, 2018 by cuchulainn16
I'm using a laptop, Windows 10, intel-based stuff. Just bought it yesterday, and so far it will only run in safe mode (from the launcher) using software rendering mode. Any attempt at using 3d acceleration kicks me out. I'm a little irritated, as it shouldn't be too much to ask for something to work as it comes to me, without having to track down 3rd-party fixes and what-all.
avatar
mkell_226: I'm using a laptop, Windows 10, intel-based stuff. Just bought it yesterday, and so far it will only run in safe mode (from the launcher) using software rendering mode. Any attempt at using 3d acceleration kicks me out. I'm a little irritated, as it shouldn't be too much to ask for something to work as it comes to me, without having to track down 3rd-party fixes and what-all.
Hi,

Just ran into this issue on my laptop, the game would try to start normally and crash.
The game tries to start the GL version on the Intel card and for some reason, that does not work. Fortunately, the laptop has 2 GPU's.

I got it to work by going to the Nvidia Control Panel and under "Manage 3D settings - Program Settings" locate or add the game executable and set it to run on the "High performance Nvidia processor"
Alternatively, on Windows 10 you can do this by navigating to : Windows Settings - System - Display - Graphics Settings". Browse and locate the quake 2 executable then select "High Performance"

I've tried all i could think of but was not able to get it to run on the Intel GPU.
avatar
milutza: ...
Oddly enough, I was able to get it running quite easily on MacOS using GLQuake or something like that. Oh well!
The solution is simple but effective:

1. Download Yamagi Quake II here.
2. Copy the contents of the archive into your game directory.
3. Start and enjoy your game!

Supported renderer: Software / OpenGL1.4 / OpenGL3.2 / Custom
Supported Operating Systems: Windows / Mac OS

Have fun!
ZerTerO
Post edited May 28, 2020 by ZerTerO
I've not been able to get Quake 2 to run properly for years. Gave up.

I just read your post and went and got this Yamagi file.....7.43

I saved it into the GoG Galaxy/Games/Quake 2 folder.

Didn't help. The game starts, but in a TINY window. I mean tiny, when I say tiny.

I also tried to unzip this file, thinking that was needed . I use 7 Zip. Nothing happens.

I see no Read Me or instructions on this site link. Sure would be helpful.
avatar
billybgame: I see no Read Me or instructions on this site link. Sure would be helpful.
Place the Yamagi files into your Quake 2 game folder, then start the game using "yquake2.exe" and then change the resolution to whatever you want in the games video options.
avatar
billybgame: I see no Read Me or instructions on this site link. Sure would be helpful.
avatar
Berzerk2002: Place the Yamagi files into your Quake 2 game folder, then start the game using "yquake2.exe" and then change the resolution to whatever you want in the games video options.
I don't see that file name in my Quake 2 folder. I put the Yamagi file in there, as I said. Didn't seem right so tried unzipping the file with 7 Zip, which acted oddly...not even sure it did anything.

This was why I was wondering why the file site has no instructions.

Edit:

Just did some Googling.....I hace this tar.zx file...I see that's a Linux file. Is that what I'm supposed to have? Maybe that's why it's messed up and not working.
Post edited July 27, 2020 by billybgame
avatar
billybgame: Just did some Googling.....I hace this tar.zx file...I see that's a Linux file. Is that what I'm supposed to have? Maybe that's why it's messed up and not working.
You need to download the "Precompiled Windows binaries" file if you're a Windows user.
avatar
billybgame: Just did some Googling.....I hace this tar.zx file...I see that's a Linux file. Is that what I'm supposed to have? Maybe that's why it's messed up and not working.
avatar
Berzerk2002: You need to download the "Precompiled Windows binaries" file if you're a Windows user.
Not sure why this Yamagi site needs to be like it's written for IT people. Why can't there be some specific instructions?

So, I see that Windows Binary download. Downloaded it. Tried unzipping.....seems odd again. Don't see any Yquake.exe.

Do I need to re-download or re-install the Yamagi Quake files then?

This is why a readme or instructions seem gravely lacking.
avatar
billybgame: Do I need to re-download or re-install the Yamagi Quake files then?
• Install Quake II: Quad Damage
• Download the "Precompiled Windows binaries" file from the Yamagi site
• Extract all the files from "Precompiled Windows binaries" into your Quake II: Quad Damage game folder
• Run "yquake2.exe" and configure the game the way you want

If you don't see the "yquake2.exe" check if your antivirus software keeps deleting that file for whatever reason. Wouldn't be the first time such a program caused unnecessary problems with a tottally harmless exe file.
Post edited July 28, 2020 by Berzerk2002
if the game don't start see if you have in quake 2 main folder wimm.dll and erase it
unmoded game, at least in my case worked, I have windows 7.
Post edited August 16, 2020 by ursu1
Just an FYI: Quake (on different launcher) didn't work for me until I turned off DEP
//forums.tomshardware.com/faq/how-to-manage-dep-in-windows-10.3272801/