It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

When I make a fresh install of Quake 2 without any patches or source ports I have this odd issue where I'll bring up the GOG launcher, select to run the game, and then my desktop goes into Windows 7 Basic mode but the game won't launch for some reason. If I bring up the launcher again and choose "run" again then suddenly NOW the game launches, but when I close out of the game it stays stuck in Windows 7 Basic mode and won't let me change it back to normal in my settings. A similar odd thing happens when I don't use the launcher where if I choose quake2.exe directly it won't launch at first, but then it does on the second time I double click. It won't go into Windows 7 Basic this way but for some reason then I can't seem to launch the expansions via the console (though maybe I'm doing something wrong there I admit) so I feel like I kinda need the GOG launcher.

I then installed the 3.24 fan patch and it still does the same stuff I described above so I wonder if there's some odd issue with the GOG launcher for the game or what. Another bit of weirdness, when I closed out the game and then decided to delete the files to make another fresh install my computer told me it can't delete the music files because they were already in use by quake2.exe, which made me go "but I closed the game, why is it acting like it's still running?" (plus it wasn't showing up in task manager). After I rebooted my computer I went back to the Quake 2 folder and now it let me delete those files no problem, but the fact it happened to begin with still perplexes me.

I'm gonna try a source port next to see if that will fix some of these oddities but it does feel odd to me that GOG's official launcher and non patched downloads have this weird issue.

UPDATE: Tried a source port and the same issue happened. And I checked task manager more carefully this time and yeah for some reason the Quake 2 application doesn't seem to close properly when exiting the game though I can't tell if this is only when the GOG launcher for Quake 2 is used, I had to end process and then it would allow me to do things like delete the wimm and liborbis files that it tells me it can't delete when the Quake 2 application is still running. This makes me think the issue might also have to do with those files. Also once again computer got stuck in Windows 7 Basic mode and had to reboot to get it to change back to normal.

I'm starting to narrow down what it might be that's causing this odditity but I'm still not 100% on what the heck this issue could be. Might try seeing if the alternate music files in that one sticked thread might help since it seems GOG's music files may be one of the culprits here.
Post edited June 19, 2019 by SubjectDeltaZero
Google it "rundll32.exe freeze".
Required REGEDIT-ing or turn on\off intenet, or some other. Dont remember. It a Windows Games service bug (Win7 and 8 100%). Or you can try wait 5 minutes - games mostly run after that. But not always.

Im always run games twice and then alt-tab to Task Manager and kill process(-trees) on rundll32. It random - some games stop working without internet, some - with internet. Useuly two games starting like that - so im first run one, hen run another. First game (rundll32) then killed in TM.

For GOG version you must download two dll files from support page. Better buy Steam version as well and combine them. GOGLauncher - trash from lamers. And GOG did not updated Quake 2 - it uses wrong dll (without downoading from support), it uses old wrong laucnher.

Check all exe files in game folder and remove any compatibility. Then set "disable theme"\"disable menu theme" and "admin run" only on Quake2.exe. or if you still want use GOGLauncher.exe - only on launcher.
So I found out how to not only "fix" this issue with Quake 2 but also Quake 4 as it was doing the same thing. With Quake 2 I found if I launched the game via clicking the "yquake2" exe in my folder after putting the Yamagi Quake II files in there it'd start up just fine with zero issue and I wouldn't get the rundll32 issue mentioned above. I legit had a thought of "wait what if...?" and I changed the NAME of the Quake 4 exe to "yquake4" and guess what? Totally worked. How in the world does simply changing the exe's name in such a way that it's no longer simply just "Quake[insert number here]" suddenly do this? I can only assume it's because that rundll32 thing is specifically only activating for games that have very specific names for their exe.

Weird as all hell solution but hey I'm glad I found it.
It cause Windows Games *somewhat* service, that have DB of old games exe names.
I know, this thread is quiet old, but for anyone who have this problem, too.

Goto your game-folder (default: "C:/GOG Games/Quake2")
The quake2.exe doesn't work properly, you need to start it twice.
BUT at the bottom of the folder you may find a yquake2.exe. This works to 100% and will be used automaticly as soon you started the quake2.exe the second time, too.

If you want to use the GOGLauncher, simply open the "Q2Launcher.ini" with a editor, with a search and replace function. (like Notepad++) and search for "quake2.exe" and replace anything with "yquake2.exe".

Have fun. xD
Post edited October 02, 2019 by Ninetonine
or may not found
Ninetonine: BUT at the bottom of the folder you may find a yquake2.exe. This works to 100% and will be used automaticly as soon you started the quake2.exe the second time, too.
Because it's the EXE for the source port Yamagi Quake 2.