It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The game doesn't save my progress, nor my settings.

When I quit, whatever progress I have made is lost when I restart the game. It's strange, because supposedly it does write *something* to disk and cloud saves are synched. But when I relaunch the game, I have to start from scratch.

Any idea what the problem could be? And how to solve it?

Edit: I also own the game on Steam. It's not installed there now, but could it have left some files somewhere that are confusing the GOG version of the game?
Post edited March 09, 2018 by JoshoB
No posts in this topic were marked as the solution yet. If you can help, add your reply
So I uninstalled the game, scrubbed my registry, and reinstalled. Same problem.

If I select "Exit campaign", the game just reverts to where I was before. I don't get to see the main menu.

Display settings always revert to default when restarting the game. Checkpoints aren't saved: I always have to start from scratch.

I'll contact support in the meantime.
Post edited March 09, 2018 by JoshoB
I installed it on another PC and it worked fine.

I dug through the game's files in its installation directory and I managed to solve the issue. I've never experienced anything like this, but here's the solution that worked.

Inside the game's "Content" directory, there's a folder called "ConfigOptions". I think these were used during testing -- they don't seem to be needed at all. However, my computer's name is MSI and one of the configuration files in that directory is called MSI.xml. I checked the file and one of the options it has is "<DirectLoad>Campaign</DirectLoad>".

This is what prevented me from seeing the main menu. It also messed up the saves -- the game *does* save checkpoints, just it never loaded automatically, reverting instead to another part of the game, because of this setting: "<SkipIntroMatch>true</SkipIntroMatch>".

Deleting or renaming the "ConfigOptions" folder fixed my problem. The game now loads to the main menu and I can pick a profile and play the game, access Versus Mode, and so on.

So if anyone runs into a similar problem, this is the fix.
r u using gog installer or goggalaxy?