It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Been making my way through the trilogy, and man, is the third game buggy.

I got to the save point "The Plaza" after the Dark Prince fights the second boss.

There's a point where you need to run up a wall, jump off and use the chain to swing up to a wooden bar. - See @ 1:30 mark, where he swings over the bar and lands on it.

My problem is, whenever I do this, the Prince never goes above the bar- he keeps swinging just under it.

I tried switching CPU affinity, tried with Vsynch on and off- nothing seems to work, and he keeps swinging under.

Any ideas as to why? All help would be greatly appreciated.

my specs: AMD FX 8350, GTX 1060, 16 GB RAM.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Unfortunately glitches such as this one aren't easy to circumvent.

In general, you have already tried the most logical solutions: setting the game to use only one CPU core and turning on Vsync.
I suggest you to insist trying with these settings, maybe adding the option to run the game in compatibility mode for Windows XP.
Cap FPS to 60 in cases like that (considering you are using high refresh monitor).
I was eventually able to get past this by running the game in XP compatibility mode, and maxing out all settings to strain the CPU enough to slow it down.

overall, it is a buggy, unoptimized mess of a game, even though the mechanics and story are quite decent.