It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi Folks,

Had a problem getting the "New Game" option to load. It would just hang.

I am using Win 10 Pro (x64) ver 1809. Core i7 2600K, 8GB DDR3 1866, nVidia Geforce GTX1060 6GB.

It seems to be a DirectX problem. I fixed it using the patch and instructions on a Github post. I can't post the link (because of forum restrictions - fair play) but you can search for it on Github > elishacloud > dxwrapper > wiki > Prince-of-Persia

GOG might consider looking into the issue. Hint, hint. ;)

As always, use your best security practices when installing anything off the internet.


It's an enjoyable enough game, but I think I prefer the games from the older series though. (Controls are fiddly with this 2008 reboot.) Have been also found lockups on boss fights, even with the graphics set well below my hardware capability.
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
WyrdWillow:
Thank you! I had the same issue on Win 8.1, and this fixed it. :)