It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Is there any way to turn off speech subtitles? Game options only seem to have voice+text and text only mode. Would like to play in voice only mode so I can concentrate on the the game and scene without having the text on the screen. Thanks
No posts in this topic were marked as the solution yet. If you can help, add your reply