It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

After the GT logo and the small video, when you must enter your name, you can move the mouse pointer for a sec or so, and then it stops responding. It happens just the same with the keyboard. I begin to delete the default name "Rasputin", but then after a second or so the controls stops responding. All I can do then is ctr+alt+del and wait for the task manager to show up so I can kill the process. Once the task manager appears, the mouse pointer stars to respond/move so damn slow it's really difficult not to lose your temper when trying to kill the Poweslide process. Sometimes I have to kill explorer.exe too to get back control of Windows.

My specs:

Windows 7 64
Intel C2D E6600
Nvidia GTX260OC

I've tried installing nglide. Same result. Any hints?
No posts in this topic were marked as the solution yet. If you can help, add your reply
I have no idea, I suggest to contact support for this one.