It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've tried running the game as administrator and every option in Config but it crashes every time I hover over any button in the menu (single player, multi player, race, ...). :/

I use Win 7 and the error says (in german):

Problemereignisname: BEX
Anwendungsname: powerslide.exe
Anwendungszeitstempel: 363c8c3f
Fehlermodulname: powerslide.exe
Fehlermodulzeitstempel: 363c8c3f
Ausnahmeoffset: 000f3ad0
Ausnahmecode: c0000005
Ausnahmedaten: 00000008
Betriebsystemversion: 6.1.7601.
Gebietsschema-ID: 1031
Zusatzinformation 1: 77f3
Zusatzinformation 2: 77f3029625ae9aaf1fae45770a719df3
Zusatzinformation 3: 2550
Zusatzinformation 4: 2550a640d1ee62c2abda55c78aff3c63

Does anybody know how to fix this?

No posts in this topic were marked as the solution yet. If you can help, add your reply
My game was crashing whenever I hovered over a menu button as well, though I didn't get any kind of error message. Just a straight crash to desktop.

I fixed it by disabling Data Execution Prevention.

If you (or anyone else with this problem) need a step-by-step guide, here goes:

- In the Control Panel, open System
- Go to 'Advanced system settings'
- Click on the 'Advanced' tab
- Click the 'Settings' button under 'Performance'
- Go to the 'Data Execution Prevention' tab
The radio button 'Turn on DEP for all programs and services except those I select' should be active.
- Click 'Add', and select powerslide.exe.

Hopefully, this should get the game running. I can't get mine to go above 1024x768, even if I use a wrapper, and the mouse is incredibly sluggish in the menus, but I can play the game, and that's the best I've managed in a long time.

Good luck!
Thank you very much, Rublore!

I've followed your guide but without success.

The approach with DEP looked familiar and actually I've tried it for another game, I've struggled to get running (acid arena monster blast, a quake III fps on psychedelics). But it did not work back then, so maybe it's just on my machine.

Nonentheless, thank you!
This method is no longer relevant on current Windows 10 PCs. When I click on system in the control panel, it takes me straight to the system page of the built in settings window, so I can't follow the rest of the walkthrough as it takes me out of the control panel and where it has led me has left me completely lost on where to find the Data Execution settings!