It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm trying to play Powerslide and I'm experiencing a very frustrating issue. The game runs fine for one race, but when I try to start a second race, the game gets stuck on a blank screen and doesn't start the race. The menu music keeps playing, but the game is completely unresponsive. I can't even open task manager to kill the process (because the window opens behind the blank Powerslide screen) so it forces a hard reset of my system.

The issue does not occur when running in software mode, it only happens when I'm using a 3D hardware mode. Obviously, the game looks like buttcheeks in software mode so I don't consider this an acceptable solution.


Windows 10 64 bit
Intel Core i7-10700
Nvidia GeForce RTX 2070 Super 8GB

I've tried pretty much everything I can think of:

- Downloaded the latest version of nGlide and copied the appropriate files into the game folder
- Ran nglide_config.exe and tried pretty much every combination of settings in there
- Opened the game's config/command line options and ticked on various combinations of -forced3d, -forceglide2 and -d3dflip
- Tried different graphics settings within the game itself

Nothing works. The problem just keeps happening regardless of what I try. Game runs fine the first time you do a race, but doesn't work if you select to do a second race (even if it's on the same track in the same game mode).

100% repro:

1. Start game
2. Start a single race
3. Exit the race (or complete it)
4. Start another single race

Expected result:

Race starts and game is playable as normal

Actual result:

Game is stuck on a blank screen and is unresponsive
No posts in this topic were marked as the solution yet. If you can help, add your reply
After fighting this for a whole day I finally found a solution, so posting this here in case anyone else runs into the problem.

First of all, don't launch the game from GOG Galaxy. Instead, launch it directly from the game install folder with the "Launch Powerslide" shortcut. I don't know what shortcut GOG Galaxy uses, but it's not this one.

Before launching the game, right click on the shortcut, then select Properties, then select the Compatibility tab. In the "Settings" box, you should see the option "Disable fullscreen optimizations". You want to check this box.

Then select the Shortcut tab, click Advanced, and make sure "Run as Administrator" is also checked.

Click Apply, Click OK, and that's it. Just make sure you launch the game from the shortcut in the install folder and not from GOG Galaxy, and you'll be fine. I don't know why "Disable fullscreen optimizations" works, but it does.