It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I keep getting this error whenever I begin the game. I assume it has something to do with save game location, which is supposed to be in the "My Documents" folder. I'm running the game as admin in Windows 8.1. I can't seem to find any place where I can change the options so it stops trying to find Drive D: which doesn't exist on my PC (hard disk is C). Any way to fix this?
No posts in this topic were marked as the solution yet. If you can help, add your reply
nucleardonut: Any way to fix this?
Have you tried running the game explicitly with admin rights by right-clicking the game's shortcut and selecting the option to run it as an administrator?

Also don't install the game into Program Files but into a custom folder on C:, e.g. C:\GOG Games\

GOG support usually suggests disabling User Account Control (UAC) in this case. On Win 7 it's done here:
Control Panel => User Accounts and Family Safety => User Accounts => Change User Account Control settings
Move the slider to the lowest position ("Never notify") and click OK. Afterwards, make sure to always launch the game as an Administrator like mentioned above.
Post edited February 09, 2015 by DeMignon
It's installed in C: GOG Games, exactly where the GOG installer put it. It's set to run as admin, which is how GOG set it during the install.

Again, my guess is that it's looking for a save file on drive D, when it should be looking for drive C. I need to change that (there is no drive D on my PC) but I have no idea how. There's nothing in the config or install files, nothing under options that let's me do that.

Am I the only person having this issue? I find that hard to believe.
Some issues with games asking for CDs only appear when there's no CD/DVD drive at all in your system. To circumvent this you can install a virtual drive (e.g. with Virtual CloneDrive)