It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
nvm
Post edited October 24, 2017 by Honigkiller
exact same issue as the last post please help
avatar
Honigkiller: It just says "program crashed" after starting it and i hate wasting money so please help greatly appreciated
Which one, please? There's 3 Populous games.
avatar
Honigkiller: It just says "program crashed" after starting it and i hate wasting money so please help greatly appreciated
avatar
Darvond: Which one, please? There's 3 Populous games.
Popoulus beginning or smth but doesnt matter found out how to start it after an hour and some guides and videos.
avatar
yoshie108: exact same issue as the last post please help
Althought GOG galaxy warns the incompatibility with windows greater thant 7, I ran it in windows 10 64 bit. Also I know there are problems in launching the game in windows 7. The problem is with the D3DPopTB. exe file. The popTB.exe file will work but with bizarre colors. Here I present a recipe that allowed to run populous with nice colors, at least it worked in my PC computer (I hope it works in everyone):

1- Download DGvoodoo from http://dege.fw.hu/dgVoodoo2/dgVoodoo2.html (I used last version, no virus at all)
2- After downloading extract the archive. Open it and go to MS folder. Inside you should be able to find:
D3D8.dll
D3DImm.dll
DDraw.dll

3- Copy these 3 .dll files into the game installation folder (the default is C:\GOG Games\game-name)
4- Execute D3DPopTB

This is not the end. You will see a good resolution but with some kind of strange "fluorescence" like the game being radioactive (I don't find the proper words). Press Esc, go to options, graphics. If you change the resolution to "high" the graphics will look nice, but you will have problmes with your mousse. You wont be able to move it correctly. So choose low resolution or medium. Then press the left bottom mouse in the "gamma correction" cursor and then it is magic: not only the colors will be nice, but also you wont have problems with the mouse controll.

This not all, because when you pass the level and try to play the next one the screen will look black (but the game is still running). Just press alt tab and re enter the game by clicking on the icon game (dont exit the game). Now again the same trick. Go to options, graphics, gamma correction and click on the cursor.

Perhaps you need to click on the dgVoodoo setup file (that is in the game installation folder) and change some launch options. I did it, but I don't know exactly if that made any contribution in running the game. The important thing is what I described above.
thanks so much termotanque, i've never had this game working for me before. just the 4 steps above worked fine for me. also had Populous Undiscovered Worlds working as well.
what's strange though is i didn't experience any of the strange colours you mentioned, everything in the game worked great for me straight after copying the files across (except for a little graphical stuttering). i used ver. 2.54 of dgvoodoo.

i'm using Win10 x64 Pro with all updates

thanks again!
avatar
yoshie108: exact same issue as the last post please help
avatar
termotanque: Althought GOG galaxy warns the incompatibility with windows greater thant 7, I ran it in windows 10 64 bit. Also I know there are problems in launching the game in windows 7. The problem is with the D3DPopTB. exe file. The popTB.exe file will work but with bizarre colors. Here I present a recipe that allowed to run populous with nice colors, at least it worked in my PC computer (I hope it works in everyone):

1- Download DGvoodoo from http://dege.fw.hu/dgVoodoo2/dgVoodoo2.html (I used last version, no virus at all)
2- After downloading extract the archive. Open it and go to MS folder. Inside you should be able to find:
D3D8.dll
D3DImm.dll
DDraw.dll

3- Copy these 3 .dll files into the game installation folder (the default is C:\GOG Games\game-name)
4- Execute D3DPopTB

This is not the end. You will see a good resolution but with some kind of strange "fluorescence" like the game being radioactive (I don't find the proper words). Press Esc, go to options, graphics. If you change the resolution to "high" the graphics will look nice, but you will have problmes with your mousse. You wont be able to move it correctly. So choose low resolution or medium. Then press the left bottom mouse in the "gamma correction" cursor and then it is magic: not only the colors will be nice, but also you wont have problems with the mouse controll.

This not all, because when you pass the level and try to play the next one the screen will look black (but the game is still running). Just press alt tab and re enter the game by clicking on the icon game (dont exit the game). Now again the same trick. Go to options, graphics, gamma correction and click on the cursor.

Perhaps you need to click on the dgVoodoo setup file (that is in the game installation folder) and change some launch options. I did it, but I don't know exactly if that made any contribution in running the game. The important thing is what I described above.
This worked for me with the dgVoodoo2 2.54. With the 2.55 I got a weird very small version of the game.