It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Am I missing something or is there not a way to disable the games anti aliasing? It appears to use the blurry everything up method. I would rather use driver settings for AA, or I would even prefer going without if it means everything is clearer.
Im still not fully behind the blurry look, but things like making the resource rocks more clearly visible as resource rocks do fix the real issues I have with it. Thanks for that, Craneballs. Its appreciated.